summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2016-03-19 23:18:05 +0000
committerAnthony G. Basile <blueness@gentoo.org>2016-03-20 11:42:55 -0400
commitd5fb469859f75c12eb5874dedcd0be3026179a1c (patch)
treee0a48073381b9d276c7cb7b36fcc857bc953d8d8 /net-libs/libbitcoinconsensus/files
parentdev-libs/univalue: initial commit, version 1.0.2 (diff)
downloadgentoo-d5fb469859f75c12eb5874dedcd0be3026179a1c.tar.gz
gentoo-d5fb469859f75c12eb5874dedcd0be3026179a1c.tar.bz2
gentoo-d5fb469859f75c12eb5874dedcd0be3026179a1c.zip
net-p2p/bitcoin*: bump all pkgs to 0.12.0 and update 9999
Diffstat (limited to 'net-libs/libbitcoinconsensus/files')
-rw-r--r--net-libs/libbitcoinconsensus/files/9999-syslibs.patch114
-rw-r--r--net-libs/libbitcoinconsensus/files/bugfix_bench_checks.patch69
2 files changed, 131 insertions, 52 deletions
diff --git a/net-libs/libbitcoinconsensus/files/9999-syslibs.patch b/net-libs/libbitcoinconsensus/files/9999-syslibs.patch
index 2cdf2ab9837b..c594c54634ed 100644
--- a/net-libs/libbitcoinconsensus/files/9999-syslibs.patch
+++ b/net-libs/libbitcoinconsensus/files/9999-syslibs.patch
@@ -12,10 +12,10 @@ index 66f106c..5f0a3b1 100644
if test "x${newinclpath}" != "x"; then
eval "$1=\"\$$1\"' -I${newinclpath}'"
diff --git a/configure.ac b/configure.ac
-index 37fe47e..14e5c34 100644
+index 939dfea..6c9acb3 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -170,6 +170,18 @@ AC_ARG_WITH([utils],
+@@ -200,6 +200,18 @@ AC_ARG_WITH([utils],
[build_bitcoin_utils=$withval],
[build_bitcoin_utils=yes])
@@ -34,7 +34,7 @@ index 37fe47e..14e5c34 100644
AC_ARG_WITH([libs],
[AS_HELP_STRING([--with-libs],
[build libraries (default=yes)])],
-@@ -488,14 +500,65 @@ if test x$use_reduce_exports = xyes; then
+@@ -531,14 +543,65 @@ if test x$use_reduce_exports = xyes; then
[AC_MSG_ERROR([Cannot set default symbol visibility. Use --disable-reduce-exports.])])
fi
@@ -101,16 +101,16 @@ index 37fe47e..14e5c34 100644
if test x$enable_wallet != xno; then
dnl Check for libdb_cxx only if wallet enabled
BITCOIN_FIND_BDB48
-@@ -515,7 +578,7 @@ BITCOIN_QT_INIT
+@@ -558,7 +621,7 @@ BITCOIN_QT_INIT
dnl sets $bitcoin_enable_qt, $bitcoin_enable_qt_test, $bitcoin_enable_qt_dbus
- BITCOIN_QT_CONFIGURE([$use_pkgconfig], [qt4])
+ BITCOIN_QT_CONFIGURE([$use_pkgconfig], [qt5])
-if test x$build_bitcoin_utils$build_bitcoind$bitcoin_enable_qt$use_tests = xnononono; then
+if test x$build_bitcoin_cli$build_bitcoin_tx$build_bitcoind$bitcoin_enable_qt$use_tests = xnonononono; then
use_boost=no
else
use_boost=yes
-@@ -701,9 +764,13 @@ AC_MSG_CHECKING([whether to build bitcoind])
+@@ -848,9 +911,13 @@ AC_MSG_CHECKING([whether to build bitcoind])
AM_CONDITIONAL([BUILD_BITCOIND], [test x$build_bitcoind = xyes])
AC_MSG_RESULT($build_bitcoind)
@@ -127,7 +127,7 @@ index 37fe47e..14e5c34 100644
AC_MSG_CHECKING([whether to build libraries])
AM_CONDITIONAL([BUILD_BITCOIN_LIBS], [test x$build_bitcoin_libs = xyes])
-@@ -826,7 +893,7 @@ else
+@@ -975,7 +1042,7 @@ else
AC_MSG_RESULT([no])
fi
@@ -136,34 +136,54 @@ index 37fe47e..14e5c34 100644
AC_MSG_ERROR([No targets! Please specify at least one of: --with-utils --with-libs --with-daemon --with-gui or --enable-tests])
fi
-@@ -895,8 +962,10 @@ PKGCONFIG_LIBDIR_TEMP="$PKG_CONFIG_LIBDIR"
- unset PKG_CONFIG_LIBDIR
- PKG_CONFIG_LIBDIR="$PKGCONFIG_LIBDIR_TEMP"
+@@ -1062,8 +1129,10 @@ if test x$system_univalue = xno; then
+ AC_CONFIG_SUBDIRS([src/univalue])
+ fi
+if test x$system_libsecp256k1 = xno; then
- ac_configure_args="${ac_configure_args} --disable-shared --with-pic --with-bignum=no"
+ ac_configure_args="${ac_configure_args} --disable-shared --with-pic --with-bignum=no --enable-module-recovery"
AC_CONFIG_SUBDIRS([src/secp256k1])
+fi
AC_OUTPUT
-diff --git a/qa/pull-tester/rpc-tests.sh b/qa/pull-tester/rpc-tests.sh
-index 9b31865..5bb187c 100755
---- a/qa/pull-tester/rpc-tests.sh
-+++ b/qa/pull-tester/rpc-tests.sh
-@@ -57,7 +57,7 @@ testScriptsExt=(
- extArg="-extended"
- passOn=${@#$extArg}
-
--if [ "x${ENABLE_BITCOIND}${ENABLE_UTILS}${ENABLE_WALLET}" = "x111" ]; then
-+if [ "x${ENABLE_BITCOIND}${ENABLE_CLI}${ENABLE_WALLET}" = "x111" ]; then
- for (( i = 0; i < ${#testScripts[@]}; i++ ))
- do
- if [ -z "$1" ] || [ "${1:0:1}" == "-" ] || [ "$1" == "${testScripts[$i]}" ] || [ "$1.py" == "${testScripts[$i]}" ]
-diff --git a/qa/pull-tester/tests-config.sh.in b/qa/pull-tester/tests-config.sh.in
-index 10f4d33..e0e407d 100755
---- a/qa/pull-tester/tests-config.sh.in
-+++ b/qa/pull-tester/tests-config.sh.in
+diff --git a/qa/pull-tester/rpc-tests.py b/qa/pull-tester/rpc-tests.py
+index 7649c11..978419b 100755
+--- a/qa/pull-tester/rpc-tests.py
++++ b/qa/pull-tester/rpc-tests.py
+@@ -36,8 +36,8 @@ if not vars().has_key('ENABLE_WALLET'):
+ ENABLE_WALLET=0
+ if not vars().has_key('ENABLE_BITCOIND'):
+ ENABLE_BITCOIND=0
+-if not vars().has_key('ENABLE_UTILS'):
+- ENABLE_UTILS=0
++if not vars().has_key('ENABLE_CLI'):
++ ENABLE_CLI=0
+ if not vars().has_key('ENABLE_ZMQ'):
+ ENABLE_ZMQ=0
+
+@@ -141,7 +141,7 @@ def runtests():
+ coverage = RPCCoverage()
+ print("Initializing coverage directory at %s\n" % coverage.dir)
+
+- if(ENABLE_WALLET == 1 and ENABLE_UTILS == 1 and ENABLE_BITCOIND == 1):
++ if(ENABLE_WALLET == 1 and ENABLE_CLI == 1 and ENABLE_BITCOIND == 1):
+ rpcTestDir = buildDir + '/qa/rpc-tests/'
+ run_extended = '-extended' in opts
+ cov_flag = coverage.flag if coverage else ''
+@@ -187,7 +187,7 @@ def runtests():
+ coverage.cleanup()
+
+ else:
+- print "No rpc tests to run. Wallet, utils, and bitcoind must all be enabled"
++ print "No rpc tests to run. Wallet, cli, and bitcoind must all be enabled"
+
+
+ class RPCCoverage(object):
+diff --git a/qa/pull-tester/tests_config.py.in b/qa/pull-tester/tests_config.py.in
+index 937b423..71a917c 100644
+--- a/qa/pull-tester/tests_config.py.in
++++ b/qa/pull-tester/tests_config.py.in
@@ -8,7 +8,7 @@ EXEEXT="@EXEEXT@"
# These will turn into comments if they were disabled when configuring.
@@ -171,31 +191,24 @@ index 10f4d33..e0e407d 100755
-@BUILD_BITCOIN_UTILS_TRUE@ENABLE_UTILS=1
+@BUILD_BITCOIN_CLI_TRUE@ENABLE_CLI=1
@BUILD_BITCOIND_TRUE@ENABLE_BITCOIND=1
+ @ENABLE_ZMQ_TRUE@ENABLE_ZMQ=1
- REAL_BITCOIND="$BUILDDIR/src/bitcoind${EXEEXT}"
diff --git a/src/Makefile.am b/src/Makefile.am
-index 1c2f770..4d60ddf 100644
+index fa7a78f..cc2f2ca 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -1,4 +1,6 @@
-+if EMBEDDED_LIBSECP256K1
- DIST_SUBDIRS = secp256k1
-+endif
- AM_LDFLAGS = $(PTHREAD_CFLAGS) $(LIBTOOL_LDFLAGS)
-
-
-@@ -20,7 +22,7 @@ endif
+@@ -31,7 +31,7 @@ endif
BITCOIN_CONFIG_INCLUDES=-I$(builddir)/config
BITCOIN_INCLUDES=-I$(builddir) -I$(builddir)/obj $(BOOST_CPPFLAGS) $(LEVELDB_CPPFLAGS) $(CRYPTO_CFLAGS) $(SSL_CFLAGS)
-BITCOIN_INCLUDES += -I$(srcdir)/secp256k1/include
+BITCOIN_INCLUDES += $(libsecp256k1_CFLAGS)
+ BITCOIN_INCLUDES += $(UNIVALUE_CFLAGS)
LIBBITCOIN_SERVER=libbitcoin_server.a
- LIBBITCOIN_WALLET=libbitcoin_wallet.a
-@@ -30,10 +32,16 @@ LIBBITCOIN_UTIL=libbitcoin_util.a
+@@ -42,10 +42,16 @@ LIBBITCOIN_CLI=libbitcoin_cli.a
+ LIBBITCOIN_UTIL=libbitcoin_util.a
LIBBITCOIN_CRYPTO=crypto/libbitcoin_crypto.a
- LIBBITCOIN_UNIVALUE=univalue/libbitcoin_univalue.a
LIBBITCOINQT=qt/libbitcoinqt.a
+if EMBEDDED_LIBSECP256K1
LIBSECP256K1=secp256k1/libsecp256k1.la
@@ -210,7 +223,7 @@ index 1c2f770..4d60ddf 100644
# Make is not made aware of per-object dependencies to avoid limiting building parallelization
# But to build the less dependent modules first, we manually select their order here:
-@@ -63,8 +71,11 @@ if BUILD_BITCOIND
+@@ -79,8 +85,11 @@ if BUILD_BITCOIND
bin_PROGRAMS += bitcoind
endif
@@ -223,21 +236,18 @@ index 1c2f770..4d60ddf 100644
+ bin_PROGRAMS += bitcoin-tx
endif
- .PHONY: FORCE
+ .PHONY: FORCE check-symbols check-security
diff --git a/src/Makefile.test.include b/src/Makefile.test.include
-index 0997148..14b4deb 100644
+index 6ef6a69..1b6e759 100644
--- a/src/Makefile.test.include
+++ b/src/Makefile.test.include
-@@ -111,10 +111,12 @@ bitcoin_test_check: $(TEST_BINARY) FORCE
- bitcoin_test_clean : FORCE
- rm -f $(CLEAN_BITCOIN_TEST) $(test_test_bitcoin_OBJECTS) $(TEST_BINARY)
-
-+if EMBEDDED_LIBSECP256K1
+@@ -127,7 +127,9 @@ bitcoin_test_clean : FORCE
check-local:
@echo "Running test/bitcoin-util-test.py..."
$(AM_V_at)srcdir=$(srcdir) PYTHONPATH=$(builddir)/test $(srcdir)/test/bitcoin-util-test.py
++if EMBEDDED_LIBSECP256K1
$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C secp256k1 check
+endif
-
- %.json.h: %.json
- @$(MKDIR_P) $(@D)
+ if EMBEDDED_UNIVALUE
+ $(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C univalue check
+ endif
diff --git a/net-libs/libbitcoinconsensus/files/bugfix_bench_checks.patch b/net-libs/libbitcoinconsensus/files/bugfix_bench_checks.patch
new file mode 100644
index 000000000000..7319875e2d44
--- /dev/null
+++ b/net-libs/libbitcoinconsensus/files/bugfix_bench_checks.patch
@@ -0,0 +1,69 @@
+commit 789200f22b3aa744f6d0054a702e3f7ea6303db4
+Author: Luke Dashjr <luke-jr+git@utopios.org>
+Date: Tue Mar 1 14:14:29 2016 +0000
+
+ Bugfix: Check for bench_bitcoin being enabled where needed, and skip UniValue dependency when unused
+
+diff --git a/configure.ac b/configure.ac
+index e4fc443..a289e13 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -570,7 +570,7 @@ BITCOIN_QT_INIT
+ dnl sets $bitcoin_enable_qt, $bitcoin_enable_qt_test, $bitcoin_enable_qt_dbus
+ BITCOIN_QT_CONFIGURE([$use_pkgconfig], [qt5])
+
+-if test x$build_bitcoin_cli$build_bitcoin_tx$build_bitcoind$bitcoin_enable_qt$use_tests = xnonononono; then
++if test x$build_bitcoin_cli$build_bitcoin_tx$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench = xnononononono; then
+ use_boost=no
+ else
+ use_boost=yes
+@@ -754,7 +754,7 @@ if test x$use_pkgconfig = xyes; then
+ if test x$use_qr != xno; then
+ BITCOIN_QT_CHECK([PKG_CHECK_MODULES([QR], [libqrencode], [have_qrencode=yes], [have_qrencode=no])])
+ fi
+- if test x$build_bitcoin_utils$build_bitcoind$bitcoin_enable_qt$use_tests != xnononono; then
++ if test x$build_bitcoin_utils$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench != xnonononono; then
+ PKG_CHECK_MODULES([EVENT], [libevent],, [AC_MSG_ERROR(libevent not found.)])
+ if test x$TARGET_OS != xwindows; then
+ PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads],, [AC_MSG_ERROR(libevent_pthreads not found.)])
+@@ -779,7 +779,7 @@ else
+ AC_CHECK_HEADER([openssl/ssl.h],, AC_MSG_ERROR(libssl headers missing),)
+ AC_CHECK_LIB([ssl], [main],SSL_LIBS=-lssl, AC_MSG_ERROR(libssl missing))
+
+- if test x$build_bitcoin_utils$build_bitcoind$bitcoin_enable_qt$use_tests != xnononono; then
++ if test x$build_bitcoin_utils$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench != xnonononono; then
+ AC_CHECK_HEADER([event2/event.h],, AC_MSG_ERROR(libevent headers missing),)
+ AC_CHECK_LIB([event],[main],EVENT_LIBS=-levent,AC_MSG_ERROR(libevent missing))
+ if test x$TARGET_OS != xwindows; then
+@@ -810,6 +810,11 @@ fi
+
+ dnl univalue check
+
++AC_MSG_WARN([x$build_bitcoin_cli,$build_bitcoin_tx,$build_bitcoind,$bitcoin_enable_qt,$use_tests])
++if test x$build_bitcoin_cli$build_bitcoin_tx$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench = xnononononono; then
++ system_univalue=yes
++else
++
+ if test x$system_univalue != xno ; then
+ found_univalue=no
+ if test x$use_pkgconfig = xyes; then
+@@ -842,6 +847,8 @@ if test x$system_univalue = xno ; then
+ UNIVALUE_CFLAGS='-I$(srcdir)/univalue/include'
+ UNIVALUE_LIBS='univalue/libunivalue.la'
+ fi
++
++fi
+ AM_CONDITIONAL([EMBEDDED_UNIVALUE],[test x$system_univalue = xno])
+ AC_SUBST(UNIVALUE_CFLAGS)
+ AC_SUBST(UNIVALUE_LIBS)
+@@ -991,8 +998,8 @@ else
+ AC_MSG_RESULT([no])
+ fi
+
+-if test x$build_bitcoin_cli$build_bitcoin_tx$build_bitcoin_libs$build_bitcoind$bitcoin_enable_qt$use_tests = xnononononono; then
+- AC_MSG_ERROR([No targets! Please specify at least one of: --with-utils --with-libs --with-daemon --with-gui or --enable-tests])
++if test x$build_bitcoin_cli$build_bitcoin_tx$build_bitcoin_libs$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench = xnonononononono; then
++ AC_MSG_ERROR([No targets! Please specify at least one of: --with-utils --with-libs --with-daemon --with-gui --enable-tests or --enable-bench])
+ fi
+
+ AM_CONDITIONAL([TARGET_DARWIN], [test x$TARGET_OS = xdarwin])