summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2016-07-01 02:28:31 +0000
committerAnthony G. Basile <blueness@gentoo.org>2016-07-01 19:31:45 -0400
commitee678b46eba9e31c32c46d70a1c1124c9a067840 (patch)
tree0b6dbed659d74efc60efaa3ca5edc3b772eb33b2 /net-libs/libbitcoinconsensus/libbitcoinconsensus-0.12.1.ebuild
parentnet-p2p/bitcoind: 0.12.1 (diff)
downloadgentoo-ee678b46eba9e31c32c46d70a1c1124c9a067840.tar.gz
gentoo-ee678b46eba9e31c32c46d70a1c1124c9a067840.tar.bz2
gentoo-ee678b46eba9e31c32c46d70a1c1124c9a067840.zip
net-libs/libbitcoinconsensus: 0.12.1
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-libs/libbitcoinconsensus/libbitcoinconsensus-0.12.1.ebuild')
-rw-r--r--net-libs/libbitcoinconsensus/libbitcoinconsensus-0.12.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.12.1.ebuild b/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.12.1.ebuild
new file mode 100644
index 000000000000..063c45d523a8
--- /dev/null
+++ b/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.12.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2010-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+BITCOINCORE_COMMITHASH="9779e1e1f320a45255f2e81325f2feceec3fa944"
+BITCOINCORE_LJR_DATE="20160629"
+BITCOINCORE_LJR_PREV="rc2"
+BITCOINCORE_IUSE="test"
+BITCOINCORE_NO_DEPEND="libevent"
+inherit bitcoincore eutils
+
+DESCRIPTION="Bitcoin Core consensus library"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+src_configure() {
+ bitcoincore_conf \
+ --with-libs
+}
+
+src_install() {
+ bitcoincore_src_install
+ dodoc doc/bips.md
+ prune_libtool_files
+}