summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 21:18:28 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-10 17:03:28 +0100
commit75cc60a219910a9240526b00a23adb600852fe79 (patch)
treeff2a7b457f299ba9029a35b43acee7824106910d /net-libs/libbtbb
parentnet-libs/libbtbb: ENABLE_PYTHON=OFF so BUILD_ROOT is never used (diff)
downloadgentoo-75cc60a219910a9240526b00a23adb600852fe79.tar.gz
gentoo-75cc60a219910a9240526b00a23adb600852fe79.tar.bz2
gentoo-75cc60a219910a9240526b00a23adb600852fe79.zip
net-libs/libbtbb: Drop IUSE wireshark-plugins
Any compatible wireshark version has left the tree so drop all that cruft with bogus cmake.eclass usage. Bug: https://bugs.gentoo.org/789234 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libbtbb')
-rw-r--r--net-libs/libbtbb/libbtbb-9999.ebuild118
1 files changed, 1 insertions, 117 deletions
diff --git a/net-libs/libbtbb/libbtbb-9999.ebuild b/net-libs/libbtbb/libbtbb-9999.ebuild
index fbdd1cde9c2c..9085d00e99ef 100644
--- a/net-libs/libbtbb/libbtbb-9999.ebuild
+++ b/net-libs/libbtbb/libbtbb-9999.ebuild
@@ -21,128 +21,12 @@ fi
LICENSE="GPL-2"
SLOT="0/${PV}"
-IUSE="static-libs wireshark-plugins"
-
-RDEPEND="
- wireshark-plugins? ( >=net-analyzer/wireshark-1.8.3-r1:= )
-"
-DEPEND="${RDEPEND}
- wireshark-plugins? ( dev-libs/glib )
-"
-BDEPEND="virtual/pkgconfig"
-
-get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
-
-which_plugins() {
- if has_version '>=net-analyzer/wireshark-2.2.0'; then
- plugins=""
- elif has_version '>=net-analyzer/wireshark-1.12.0'; then
- plugins="btbb btbredr"
- elif has_version '<net-analyzer/wireshark-1.12.0'; then
- plugins="btbb btle btsm"
- fi
-}
-
-src_prepare() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake_src_prepare
-
- if use wireshark-plugins; then
- which_plugins
- for i in ${plugins}
- do
- sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake_src_prepare
- done
- fi
-}
+IUSE="static-libs"
src_configure() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
local mycmakeargs=(
-DENABLE_PYTHON=OFF
-DBUILD_STATIC_LIB=$(usex static-libs)
)
cmake_src_configure
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- local mycmakeargs=(
- -DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
- )
- cmake_src_configure
- done
- fi
-}
-
-src_compile() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake_src_compile
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake_src_compile
- done
- fi
-}
-
-src_test() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake_src_test
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake_src_test
- done
- fi
-}
-
-src_install() {
- CMAKE_USE_DIR="${S}"
- BUILD_DIR="${S}"_build
- cmake_src_install
-
- if use wireshark-plugins; then
- for i in ${plugins}
- do
- if has_version '>=net-analyzer/wireshark-2.0'; then
- CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
- else
- CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
- fi
- BUILD_DIR="${WORKDIR}"/${i}_build
- cmake_src_install
- done
- fi
}