summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 21:11:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-10 17:03:27 +0100
commitb3f6295f467a0d1ae2e48938a58bb575f02b36af (patch)
treed906452d2303f1725902f94ab27957b25b2fde26 /net-libs/libbtbb
parentsys-apps/haveged: remove older versions (diff)
downloadgentoo-b3f6295f467a0d1ae2e48938a58bb575f02b36af.tar.gz
gentoo-b3f6295f467a0d1ae2e48938a58bb575f02b36af.tar.bz2
gentoo-b3f6295f467a0d1ae2e48938a58bb575f02b36af.zip
net-libs/libbtbb: EAPI-8 bump, style fixes, HOMEPAGE, indentation
Bug: https://bugs.gentoo.org/789234 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libbtbb')
-rw-r--r--net-libs/libbtbb/libbtbb-9999.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/net-libs/libbtbb/libbtbb-9999.ebuild b/net-libs/libbtbb/libbtbb-9999.ebuild
index edbf18eed8ff..07ebc4c4767b 100644
--- a/net-libs/libbtbb/libbtbb-9999.ebuild
+++ b/net-libs/libbtbb/libbtbb-9999.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
-DESCRIPTION="A library to decode Bluetooth baseband packets"
-HOMEPAGE="http://libbtbb.sourceforge.net/"
+DESCRIPTION="Library to decode Bluetooth baseband packets"
+HOMEPAGE="https://github.com/greatscottgadgets/libbtbb"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
inherit git-r3
else
MY_PV=${PV/\./-}
MY_PV=${MY_PV/./-R}
- S=${WORKDIR}/${PN}-${MY_PV}
SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_PV}
KEYWORDS="~amd64 ~arm ~x86"
fi
@@ -24,13 +24,12 @@ SLOT="0/${PV}"
IUSE="static-libs wireshark-plugins"
RDEPEND="
- wireshark-plugins? (
- >=net-analyzer/wireshark-1.8.3-r1:=
- )
+ wireshark-plugins? ( >=net-analyzer/wireshark-1.8.3-r1:= )
"
DEPEND="${RDEPEND}
- wireshark-plugins? ( dev-libs/glib
- virtual/pkgconfig )"
+ wireshark-plugins? ( dev-libs/glib )
+"
+BDEPEND="virtual/pkgconfig"
get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }