summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libgfbgraph
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libgfbgraph')
-rw-r--r--net-libs/libgfbgraph/Manifest2
-rw-r--r--net-libs/libgfbgraph/libgfbgraph-0.2.2.ebuild44
-rw-r--r--net-libs/libgfbgraph/libgfbgraph-0.2.3.ebuild45
-rw-r--r--net-libs/libgfbgraph/metadata.xml5
4 files changed, 96 insertions, 0 deletions
diff --git a/net-libs/libgfbgraph/Manifest b/net-libs/libgfbgraph/Manifest
new file mode 100644
index 000000000000..af899262d5cd
--- /dev/null
+++ b/net-libs/libgfbgraph/Manifest
@@ -0,0 +1,2 @@
+DIST gfbgraph-0.2.2.tar.xz 263792 SHA256 66c7b1c951863565c179d0b4b5207f27b3b36f80afed9f6a9acfc5fc3ae775d4 SHA512 13f685804516b8561426386ee6c05063b838aab1451d06a586b9cc2c50cbc4fb4651b9546c779dfe4dd4a80f5c78bf8464e44f13ffa5632ec11b2d7442fa50a0 WHIRLPOOL feb4f5ac6e905e2d344f3b44e568afa9014f3215ab3c39955a27597d24069e34184e3ec30b3c2aec9ec42ab787e34d81f03286bf4903b2b9f9e5e40ebc533edc
+DIST gfbgraph-0.2.3.tar.xz 270772 SHA256 da1179083cde2b649d7491c745250a00d292e390fd620b7dd2dd95a122dae0b6 SHA512 4e03beb4172a591c7d1eb4cfac56009b0d25183168f73344d24ac47554334d1edf2c5087c523025cee5d565182a02dc7ef72adc66cff1e4ad53a1d0990d3afb8 WHIRLPOOL a81075deaf0cdef21d8b9994b96d508cafe48ab00bbf0632baacf688508b4ec678cb3073c4e83b1a0b64f2c5c032b57a4189eca42f34c278ceda8ebe8b11e172
diff --git a/net-libs/libgfbgraph/libgfbgraph-0.2.2.ebuild b/net-libs/libgfbgraph/libgfbgraph-0.2.2.ebuild
new file mode 100644
index 000000000000..c80c16898b84
--- /dev/null
+++ b/net-libs/libgfbgraph/libgfbgraph-0.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_ORG_MODULE="gfbgraph"
+
+inherit gnome2
+
+DESCRIPTION="A GObject library for Facebook Graph API"
+HOMEPAGE="https://git.gnome.org/browse/libgfbgraph/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.2"
+KEYWORDS="amd64 x86"
+IUSE="+introspection"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ net-libs/libsoup:2.4
+ net-libs/gnome-online-accounts
+ net-libs/rest:0.7
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+# FIXME: most tests seem to fail
+RESTRICT="test"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+ # Remove files installed in the wrong place
+ # Also, already done by portage
+ rm -rf "${ED}"/usr/doc
+}
diff --git a/net-libs/libgfbgraph/libgfbgraph-0.2.3.ebuild b/net-libs/libgfbgraph/libgfbgraph-0.2.3.ebuild
new file mode 100644
index 000000000000..4a8ad2edf8e3
--- /dev/null
+++ b/net-libs/libgfbgraph/libgfbgraph-0.2.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_ORG_MODULE="gfbgraph"
+
+inherit gnome2
+
+DESCRIPTION="A GObject library for Facebook Graph API"
+HOMEPAGE="https://git.gnome.org/browse/libgfbgraph/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ net-libs/libsoup:2.4
+ net-libs/gnome-online-accounts
+ net-libs/rest:0.7
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+# FIXME: most tests seem to fail
+RESTRICT="test"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+ # Remove files installed in the wrong place
+ # Also, already done by portage
+ # https://bugzilla.gnome.org/show_bug.cgi?id=752581
+ rm -rf "${ED}"/usr/doc
+}
diff --git a/net-libs/libgfbgraph/metadata.xml b/net-libs/libgfbgraph/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-libs/libgfbgraph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>