summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-07 11:06:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-07 11:41:59 +0100
commitaf515071c4813a03353ed66184b084e95aba4ba9 (patch)
tree605ac652b5fdab8e7274988d0d766ae1be402cef /net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild
parentapp-admin/mktwpol: Drops old version (diff)
downloadgentoo-af515071c4813a03353ed66184b084e95aba4ba9.tar.gz
gentoo-af515071c4813a03353ed66184b084e95aba4ba9.tar.bz2
gentoo-af515071c4813a03353ed66184b084e95aba4ba9.zip
net-libs/libgsasl: Bumped to EAPI-6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild')
-rw-r--r--net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild b/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild
index 309befdc3106..100caab4bb1a 100644
--- a/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild
+++ b/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
inherit autotools eutils
@@ -23,8 +23,12 @@ DEPEND="
RDEPEND="${DEPEND}
!net-misc/gsasl"
+PATCHES=(
+ "${FILESDIR}/${PN}-gss-extra.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-gss-extra.patch"
+ default
sed -i -e 's/ -Werror//' configure.ac || die
eautoreconf
}
@@ -35,14 +39,16 @@ src_configure() {
krb5_impl="--with-gssapi-impl="
krb5_impl+=$(has_version app-crypt/mit-krb5 && echo "mit" || echo "heimdal")
fi
- econf \
- $(use_with gcrypt libgcrypt) \
- $(use_with idn stringprep) \
- $(use_enable kerberos gssapi) \
- ${krb5_impl} \
- $(use_enable nls) \
- $(use_enable ntlm) \
+ local myeconfargs=(
+ $(use_with gcrypt libgcrypt)
+ $(use_with idn stringprep)
+ $(use_enable kerberos gssapi)
+ ${krb5_impl}
+ $(use_enable nls)
+ $(use_enable ntlm)
$(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {