summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libhackrf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libhackrf')
-rw-r--r--net-libs/libhackrf/Manifest3
-rw-r--r--net-libs/libhackrf/libhackrf-2014.04.1.ebuild29
-rw-r--r--net-libs/libhackrf/libhackrf-2014.08.1.ebuild42
-rw-r--r--net-libs/libhackrf/libhackrf-2015.07.2.ebuild46
-rw-r--r--net-libs/libhackrf/libhackrf-9999.ebuild46
-rw-r--r--net-libs/libhackrf/metadata.xml15
6 files changed, 181 insertions, 0 deletions
diff --git a/net-libs/libhackrf/Manifest b/net-libs/libhackrf/Manifest
new file mode 100644
index 000000000000..d69e61f55feb
--- /dev/null
+++ b/net-libs/libhackrf/Manifest
@@ -0,0 +1,3 @@
+DIST hackrf-2014.04.1.tar.xz 14375500 SHA256 83ef987d31d314d6d99a227a18c31c34a44e996a28841234e59e53c5d8ab5a72 SHA512 1929c7af1de0c9ad1afcf56d53c5db13ef362f3ef896f3549841eeea87aec5e1133c63da740688739278b13e772b70d510a4a1035440b5b6aad2e9438a694892 WHIRLPOOL 0fa45438b4aa84e3e16b975949cead0010f6271ec89b8e2f69fcfdbd5c5a722d803a6f7d017b272b3c71773768b32bbeae00a6a43879a9268c7d84315282a93a
+DIST hackrf-2014.08.1.tar.xz 14376904 SHA256 624c46163161896b8347a73e9edeb1188433f032df7cd00eda9a242c2a5bc98a SHA512 2bb2e9398479f635fc4cb73875d9728c689f5d29bfbdcaae661d98ecafe51d38ac8768dd4f38b87766195d9ed08757e76d790030edf6f6f572d547146287c073 WHIRLPOOL c33430279d0757e104f09ecafce2df859f33f8de9139dd6491a11d86ed3e241ba3ef298d1d0994113e695c46ab211daf573262815a8a1fc5349fd44642da3910
+DIST hackrf-2015.07.2.tar.xz 14415212 SHA256 5e3d9c36928b88cdbc0d66ee54e24e8682972dba478abfca0e31069515b870b6 SHA512 a4f7b7800ece9b260d5c8c374f5544aa55cd2e97e10c6a0b33cf476e2ad4811321ffb1308d9dfb2168b2624cd3af616d1c314ad86bcd6f4c3fd0897319fa2cbd WHIRLPOOL 8dfee4fb55be913f44d8ab905fc7c6b1fd703e16b01aa41191e97ab726a3b04d6a78670ae47c2d3bada64e38d42cabcf7f39b646fba55b436cbcab312be1f198
diff --git a/net-libs/libhackrf/libhackrf-2014.04.1.ebuild b/net-libs/libhackrf/libhackrf-2014.04.1.ebuild
new file mode 100644
index 000000000000..07879c74fe4c
--- /dev/null
+++ b/net-libs/libhackrf/libhackrf-2014.04.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="library for communicating with HackRF SDR platform"
+HOMEPAGE="http://greatscottgadgets.com/hackrf/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/hackrf"
+ S="${WORKDIR}/hackrf/host/libhackrf"
+else
+ S="${WORKDIR}/hackrf-${PV}/host/libhackrf"
+ SRC_URI="mirror://sourceforge/hackrf/hackrf-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
diff --git a/net-libs/libhackrf/libhackrf-2014.08.1.ebuild b/net-libs/libhackrf/libhackrf-2014.08.1.ebuild
new file mode 100644
index 000000000000..739343b7afdb
--- /dev/null
+++ b/net-libs/libhackrf/libhackrf-2014.08.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils udev
+
+DESCRIPTION="library for communicating with HackRF SDR platform"
+HOMEPAGE="http://greatscottgadgets.com/hackrf/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/hackrf"
+ S="${WORKDIR}/hackrf/host/libhackrf"
+else
+ S="${WORKDIR}/hackrf-${PV}/host/libhackrf"
+ SRC_URI="mirror://sourceforge/hackrf/hackrf-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's#plugdev#usb#' 53-hackrf.rules
+}
+
+src_install() {
+ cmake-utils_src_install
+ udev_dorules 53-hackrf.rules
+}
+
+pkg_postinst() {
+ einfo "Users in the usb group can use hackrf."
+}
diff --git a/net-libs/libhackrf/libhackrf-2015.07.2.ebuild b/net-libs/libhackrf/libhackrf-2015.07.2.ebuild
new file mode 100644
index 000000000000..cac4656dc3fa
--- /dev/null
+++ b/net-libs/libhackrf/libhackrf-2015.07.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils udev
+
+DESCRIPTION="library for communicating with HackRF SDR platform"
+HOMEPAGE="http://greatscottgadgets.com/hackrf/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/hackrf"
+ S="${WORKDIR}/hackrf/host/libhackrf"
+else
+ S="${WORKDIR}/hackrf-${PV}/host/libhackrf"
+ SRC_URI="https://github.com/mossmann/hackrf/releases/download/v${PV}/hackrf-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE="+udev"
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ mycmakeargs=(
+ $(cmake-utils_use_enable udev INSTALL_UDEV_RULES)
+ )
+ if use udev; then
+ mycmakeargs+=(
+ -DUDEV_RULES_GROUP=usb
+ -DUDEV_RULES_PATH="$(get_udevdir)/rules.d"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ einfo "Users in the usb group can use hackrf."
+}
diff --git a/net-libs/libhackrf/libhackrf-9999.ebuild b/net-libs/libhackrf/libhackrf-9999.ebuild
new file mode 100644
index 000000000000..cac4656dc3fa
--- /dev/null
+++ b/net-libs/libhackrf/libhackrf-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils udev
+
+DESCRIPTION="library for communicating with HackRF SDR platform"
+HOMEPAGE="http://greatscottgadgets.com/hackrf/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/hackrf"
+ S="${WORKDIR}/hackrf/host/libhackrf"
+else
+ S="${WORKDIR}/hackrf-${PV}/host/libhackrf"
+ SRC_URI="https://github.com/mossmann/hackrf/releases/download/v${PV}/hackrf-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE="+udev"
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ mycmakeargs=(
+ $(cmake-utils_use_enable udev INSTALL_UDEV_RULES)
+ )
+ if use udev; then
+ mycmakeargs+=(
+ -DUDEV_RULES_GROUP=usb
+ -DUDEV_RULES_PATH="$(get_udevdir)/rules.d"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ einfo "Users in the usb group can use hackrf."
+}
diff --git a/net-libs/libhackrf/metadata.xml b/net-libs/libhackrf/metadata.xml
new file mode 100644
index 000000000000..f347a49f850f
--- /dev/null
+++ b/net-libs/libhackrf/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>radio</herd>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">hackrf</remote-id>
+ <remote-id type="github">mossmann/hackrf</remote-id>
+ </upstream>
+</pkgmetadata>