summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-10-09 13:30:30 +0200
committerMarek Szuba <marecki@gentoo.org>2020-10-09 13:40:48 +0200
commit7438cd06fed13adf40ece985549a997d972cec27 (patch)
tree8723b1886d45b5302c8f2e917625290040a2b138 /net-libs/libhtp/libhtp-0.5.35.ebuild
parentwww-client/vivaldi-snapshot: Version 3.4.2066.37_p1 (diff)
downloadgentoo-7438cd06fed13adf40ece985549a997d972cec27.tar.gz
gentoo-7438cd06fed13adf40ece985549a997d972cec27.tar.bz2
gentoo-7438cd06fed13adf40ece985549a997d972cec27.zip
net-libs/libhtp: bump to 0.5.35
Closes: https://github.com/gentoo/gentoo/pull/17858 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/libhtp/libhtp-0.5.35.ebuild')
-rw-r--r--net-libs/libhtp/libhtp-0.5.35.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libhtp/libhtp-0.5.35.ebuild b/net-libs/libhtp/libhtp-0.5.35.ebuild
new file mode 100644
index 000000000000..4c0e8229142d
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.35.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="sys-libs/zlib[static-libs?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # The debug configure logic is broken.
+ ECONF_SOURCE=${S} \
+ econf \
+ $(usex debug '--enable-debug' '') \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+ fi
+}