summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-12-14 13:38:09 -0600
committerJohn Helmert III <ajak@gentoo.org>2021-12-14 13:40:13 -0600
commitcc263284ef21c967e53f1245482533c0353fd0b3 (patch)
tree0ab559f43b69b0f0dfe6bcd2e323a400f4d6bd92 /net-libs/libiscsi/files/libiscsi-1.19.0-fix-rdma-automagic.patch
parentdev-lang/ammonite-repl-bin: stabilize 2.4.1 for amd64, x86 (diff)
downloadgentoo-cc263284ef21c967e53f1245482533c0353fd0b3.tar.gz
gentoo-cc263284ef21c967e53f1245482533c0353fd0b3.tar.bz2
gentoo-cc263284ef21c967e53f1245482533c0353fd0b3.zip
net-libs/libiscsi: update EAPI 7 -> 8, fix rdma automagic
Closes: https://bugs.gentoo.org/829185 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-libs/libiscsi/files/libiscsi-1.19.0-fix-rdma-automagic.patch')
-rw-r--r--net-libs/libiscsi/files/libiscsi-1.19.0-fix-rdma-automagic.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/libiscsi/files/libiscsi-1.19.0-fix-rdma-automagic.patch b/net-libs/libiscsi/files/libiscsi-1.19.0-fix-rdma-automagic.patch
new file mode 100644
index 000000000000..987544ffca68
--- /dev/null
+++ b/net-libs/libiscsi/files/libiscsi-1.19.0-fix-rdma-automagic.patch
@@ -0,0 +1,26 @@
+diff --git a/configure.ac b/configure.ac
+index 5fe1deb..9efe153 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -140,6 +140,8 @@ if test x"$libiscsi_cv_HAVE_SG_IO" = x"yes"; then
+ AC_DEFINE(HAVE_SG_IO,1,[Whether we have SG_IO support])
+ fi
+
++AC_ARG_WITH([rdma], AS_HELP_STRING([--with-rdma], [Build with rdma support]))
++
+ AC_CACHE_CHECK([for iSER support],libiscsi_cv_HAVE_LINUX_ISER,[
+ AC_TRY_COMPILE([
+ #include <infiniband/verbs.h>
+@@ -147,10 +149,10 @@ AC_TRY_COMPILE([
+ #include <rdma/rdma_verbs.h>],
+ [int ibv = IBV_WC_SEND;],
+ libiscsi_cv_HAVE_LINUX_ISER=yes,libiscsi_cv_HAVE_LINUX_ISER=no)])
+-if test x"$libiscsi_cv_HAVE_LINUX_ISER" = x"yes"; then
++if test x"$libiscsi_cv_HAVE_LINUX_ISER" = x"yes" && test "x$with_rdma" = "xyes"; then
+ AC_DEFINE(HAVE_LINUX_ISER,1,[Whether we have iSER support])
+ fi
+-AM_CONDITIONAL([HAVE_LINUX_ISER], [test $libiscsi_cv_HAVE_LINUX_ISER = yes])
++AM_CONDITIONAL([HAVE_LINUX_ISER], [test "x$with_rdma" = "xyes"])
+
+ AC_CACHE_CHECK([whether libcunit is available],
+ [ac_cv_have_cunit],