summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libisds
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libisds')
-rw-r--r--net-libs/libisds/Manifest2
-rw-r--r--net-libs/libisds/libisds-0.10.ebuild59
-rw-r--r--net-libs/libisds/libisds-0.7.ebuild62
-rw-r--r--net-libs/libisds/libisds-9999.ebuild62
-rw-r--r--net-libs/libisds/metadata.xml20
5 files changed, 205 insertions, 0 deletions
diff --git a/net-libs/libisds/Manifest b/net-libs/libisds/Manifest
new file mode 100644
index 000000000000..b9167818e299
--- /dev/null
+++ b/net-libs/libisds/Manifest
@@ -0,0 +1,2 @@
+DIST libisds-0.10.tar.xz 721260 SHA256 f2cb8bddbee79070bce599556ebbde42cacac1bc3ee405ab74c3b18a3dc3996f SHA512 9b317d2a4c4e957151b0d397119460a249edb3f1d76c089fa9628551dc4f858d7c5e82bc5b363017c1193ea6a764a3aa6685f4b76fdf2f1c6c5f72436d9231cd WHIRLPOOL cb7ea1c23c15c9779ba98b15ccb3df90894135963f519603ee219f0b4db14bda3c7b11b6f8e495977fd689b47cfe45628c261cac7ba05c081e8a24efd895e19c
+DIST libisds-0.7.tar.xz 685388 SHA256 db57ca7d8bdd306dfe5ec86d22afd36cb1b859a9e72bc3293d982842cb796701 SHA512 c250d7967aee997fbbb97ab077ff0d83cbf3a5aca4cfe7885453a1e25e17e3da0c119424787cb3010febea6076f62e9150ea8d91f6d955708023df25e5b5690b WHIRLPOOL 6b7c4b22411296d8c6b3a8c222da6404c915635dc7cb79d97f36123b0e033a337b93b0acb62dacff394a2d439d1622d078c6076cf34aa2f1838e4b57f7343c2a
diff --git a/net-libs/libisds/libisds-0.10.ebuild b/net-libs/libisds/libisds-0.10.ebuild
new file mode 100644
index 000000000000..a2d9233acbd8
--- /dev/null
+++ b/net-libs/libisds/libisds-0.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base eutils
+
+DESCRIPTION="Client library for accessing ISDS Soap services"
+HOMEPAGE="http://xpisar.wz.cz/libisds/"
+SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.xz"
+KEYWORDS="~amd64 ~mips ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="+curl debug nls openssl static-libs test"
+
+COMMON_DEPEND="
+ dev-libs/expat
+ dev-libs/libxml2
+ curl? ( net-misc/curl[ssl] )
+ openssl? ( dev-libs/openssl:* )
+ !openssl? (
+ app-crypt/gpgme
+ dev-libs/libgcrypt:*
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( >=net-libs/gnutls-2.12.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !openssl? ( >=app-crypt/gnupg-2 )
+"
+
+DOCS=( NEWS README AUTHORS ChangeLog )
+
+src_prepare() {
+ base_src_prepare
+}
+
+src_configure() {
+ econf \
+ --disable-fatalwarnings \
+ $(use_with curl libcurl) \
+ $(use_enable curl curlreauthorizationbug) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable openssl openssl-backend) \
+ $(use_enable static-libs static) \
+ $(use_enable test)
+}
+
+src_install() {
+ base_src_install
+
+ prune_libtool_files --all
+}
diff --git a/net-libs/libisds/libisds-0.7.ebuild b/net-libs/libisds/libisds-0.7.ebuild
new file mode 100644
index 000000000000..ab818524b156
--- /dev/null
+++ b/net-libs/libisds/libisds-0.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+[[ ${PV} = 9999* ]] && inherit git-2 autotools
+EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
+inherit base eutils
+
+DESCRIPTION="Client library for accessing ISDS Soap services"
+HOMEPAGE="http://xpisar.wz.cz/libisds/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~mips ~x86"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="+curl debug nls static-libs test"
+
+COMMON_DEPEND="
+ app-crypt/gpgme
+ dev-libs/expat
+ dev-libs/libgcrypt:0
+ dev-libs/libxml2
+ curl? ( net-misc/curl[ssl] )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-crypt/gnupg-2
+"
+
+DOCS=( NEWS README AUTHORS ChangeLog )
+
+src_prepare() {
+ base_src_prepare
+ [[ ${PV} = 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fatalwarnings \
+ $(use_with curl libcurl) \
+ $(use_enable curl curlreauthorizationbug) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable test)
+}
+
+src_install() {
+ base_src_install
+
+ prune_libtool_files --all
+}
diff --git a/net-libs/libisds/libisds-9999.ebuild b/net-libs/libisds/libisds-9999.ebuild
new file mode 100644
index 000000000000..ab818524b156
--- /dev/null
+++ b/net-libs/libisds/libisds-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+[[ ${PV} = 9999* ]] && inherit git-2 autotools
+EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
+inherit base eutils
+
+DESCRIPTION="Client library for accessing ISDS Soap services"
+HOMEPAGE="http://xpisar.wz.cz/libisds/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~mips ~x86"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="+curl debug nls static-libs test"
+
+COMMON_DEPEND="
+ app-crypt/gpgme
+ dev-libs/expat
+ dev-libs/libgcrypt:0
+ dev-libs/libxml2
+ curl? ( net-misc/curl[ssl] )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-crypt/gnupg-2
+"
+
+DOCS=( NEWS README AUTHORS ChangeLog )
+
+src_prepare() {
+ base_src_prepare
+ [[ ${PV} = 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fatalwarnings \
+ $(use_with curl libcurl) \
+ $(use_enable curl curlreauthorizationbug) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable test)
+}
+
+src_install() {
+ base_src_install
+
+ prune_libtool_files --all
+}
diff --git a/net-libs/libisds/metadata.xml b/net-libs/libisds/metadata.xml
new file mode 100644
index 000000000000..9ac387cdd030
--- /dev/null
+++ b/net-libs/libisds/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<longdescription>
+ A library for accessing ISDS (Informační systém datových schránek
+ / Data Box Information System) SOAP services as defined in Czech ISDS Act
+ (300/2008 Coll.) and implied documents.
+</longdescription>
+<maintainer>
+ <email>petr.pisar@atlas.cz</email>
+ <name>Petr Pisar</name>
+ <description>Proxy-Maintainer. Assign bugs to him</description>
+</maintainer>
+<use>
+ <flag name="openssl">Use <pkg>dev-libs/openssl</pkg> as crypto backend
+ instead of <pkg>app-crypt/gpgme</pkg> and
+ <pkg>dev-libs/libgcrypt</pkg></flag>
+</use>
+
+</pkgmetadata>