summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libkolab/libkolab-0.5.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libkolab/libkolab-0.5.2.ebuild')
-rw-r--r--net-libs/libkolab/libkolab-0.5.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/libkolab/libkolab-0.5.2.ebuild b/net-libs/libkolab/libkolab-0.5.2.ebuild
new file mode 100644
index 000000000000..27cb19d72149
--- /dev/null
+++ b/net-libs/libkolab/libkolab-0.5.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde4-base multilib
+
+DESCRIPTION="Advanced Kolab Object Handling Library"
+HOMEPAGE="http://kolab.org"
+SRC_URI="http://mirror.kolabsys.com/pub/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2+ LGPL-2.1+ LGPL-3+"
+SLOT="4"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE="php python test"
+
+# Tests fail, last checked 0.5.2
+RESTRICT="test"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop(+)')
+ dev-lang/swig
+ >=net-libs/libkolabxml-1.0.0
+ php? ( dev-lang/php )
+ python? ( dev-lang/python )
+
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # not installed by upstream
+ sed -e "/add_subdirectory(utils)/d" -i CMakeLists.txt || die
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ $(cmake-utils_use test BUILD_TESTS)
+ $(cmake-utils_use python PYTHON_BINDINGS)
+ $(cmake-utils_use php PHP_BINDINGS)
+ )
+ kde4-base_src_configure
+}