summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libmbim/libmbim-1.12.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libmbim/libmbim-1.12.2.ebuild')
-rw-r--r--net-libs/libmbim/libmbim-1.12.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/libmbim/libmbim-1.12.2.ebuild b/net-libs/libmbim/libmbim-1.12.2.ebuild
new file mode 100644
index 000000000000..7f567e4ccf4e
--- /dev/null
+++ b/net-libs/libmbim/libmbim-1.12.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~mips ~x86"
+ SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+fi
+
+DESCRIPTION="MBIM modem protocol helper library"
+HOMEPAGE="http://cgit.freedesktop.org/libmbim/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/glib-2.32:2"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/libgudev
+ virtual/pkgconfig"
+[[ ${PV} == "9999" ]] && DEPEND+=" dev-util/gtk-doc" #469214
+
+src_prepare() {
+ [[ -e configure ]] || eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-more-warnings \
+ --disable-gtk-doc \
+ $(use_enable static{-libs,})
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${ED}/usr/$(get_libdir)/${PN}-glib.la"
+}