summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libnatpmp/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libnatpmp/files')
-rw-r--r--net-libs/libnatpmp/files/remove-static-lib-20130911.patch74
-rw-r--r--net-libs/libnatpmp/files/remove-static-lib.patch44
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS-20130911.patch53
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS-20140401.patch36
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS.patch40
-rw-r--r--net-libs/libnatpmp/files/respect-libdir-20120821.patch20
-rw-r--r--net-libs/libnatpmp/files/respect-libdir.patch19
7 files changed, 286 insertions, 0 deletions
diff --git a/net-libs/libnatpmp/files/remove-static-lib-20130911.patch b/net-libs/libnatpmp/files/remove-static-lib-20130911.patch
new file mode 100644
index 000000000000..a2c1f516c363
--- /dev/null
+++ b/net-libs/libnatpmp/files/remove-static-lib-20130911.patch
@@ -0,0 +1,74 @@
+diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
+--- libnatpmp-20130911.orig/Makefile 2013-09-13 07:00:55.874343916 -0400
++++ libnatpmp-20130911/Makefile 2013-09-13 07:03:33.733351101 -0400
+@@ -35,7 +35,6 @@
+
+ OBJS = $(LIBOBJS) testgetgateway.o natpmpc.o natpmp-jni.o
+
+-STATICLIB = libnatpmp.a
+ ifeq ($(OS), Darwin)
+ SHAREDLIB = libnatpmp.dylib
+ JNISHAREDLIB = libjninatpmp.dylib
+@@ -58,7 +57,7 @@
+
+ HEADERS = natpmp.h
+
+-EXECUTABLES = testgetgateway natpmpc-shared natpmpc-static
++EXECUTABLES = testgetgateway natpmpc-shared
+
+ INSTALLPREFIX ?= $(PREFIX)/usr
+ INSTALLDIRINC = $(INSTALLPREFIX)/include
+@@ -72,9 +71,9 @@
+
+ .PHONY: all clean depend install cleaninstall installpythonmodule
+
+-all: $(STATICLIB) $(SHAREDLIB) $(EXECUTABLES)
++all: $(SHAREDLIB) $(EXECUTABLES)
+
+-pythonmodule: $(STATICLIB) libnatpmpmodule.c setup.py
++pythonmodule: libnatpmpmodule.c setup.py
+ python setup.py build
+ touch $@
+
+@@ -82,18 +81,17 @@
+ python setup.py install
+
+ clean:
+- $(RM) $(OBJS) $(EXECUTABLES) $(STATICLIB) $(SHAREDLIB) $(JAVACLASSES) $(JNISHAREDLIB)
++ $(RM) $(OBJS) $(EXECUTABLES) $(SHAREDLIB) $(JAVACLASSES) $(JNISHAREDLIB)
+ $(RM) pythonmodule
+ $(RM) -r build/ dist/ libraries/
+
+ depend:
+ makedepend -f$(MAKEFILE_LIST) -Y $(OBJS:.o=.c) 2>/dev/null
+
+-install: $(HEADERS) $(STATICLIB) $(SHAREDLIB) natpmpc-shared
++install: $(HEADERS) $(SHAREDLIB) natpmpc-shared
+ $(INSTALL) -d $(INSTALLDIRINC)
+ $(INSTALL) -m 644 $(HEADERS) $(INSTALLDIRINC)
+ $(INSTALL) -d $(INSTALLDIRLIB)
+- $(INSTALL) -m 644 $(STATICLIB) $(INSTALLDIRLIB)
+ $(INSTALL) -m 644 $(SHAREDLIB) $(INSTALLDIRLIB)/$(SONAME)
+ $(INSTALL) -d $(INSTALLDIRBIN)
+ $(INSTALL) -m 755 natpmpc-shared $(INSTALLDIRBIN)/natpmpc
+@@ -142,20 +140,13 @@
+ $(RM) $(addprefix $(INSTALLDIRINC), $(HEADERS))
+ $(RM) $(INSTALLDIRLIB)/$(SONAME)
+ $(RM) $(INSTALLDIRLIB)/$(SHAREDLIB)
+- $(RM) $(INSTALLDIRLIB)/$(STATICLIB)
+
+ testgetgateway: testgetgateway.o getgateway.o
+ $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+-natpmpc-static: natpmpc.o $(STATICLIB)
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+-
+ natpmpc-shared: natpmpc.o $(SHAREDLIB)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+-$(STATICLIB): $(LIBOBJS)
+- $(AR) crs $@ $?
+-
+ $(SHAREDLIB): $(LIBOBJS)
+ ifeq ($(OS), Darwin)
+ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
diff --git a/net-libs/libnatpmp/files/remove-static-lib.patch b/net-libs/libnatpmp/files/remove-static-lib.patch
new file mode 100644
index 000000000000..dae64601b9cb
--- /dev/null
+++ b/net-libs/libnatpmp/files/remove-static-lib.patch
@@ -0,0 +1,44 @@
+--- libnatpmp-20110715/Makefile
++++ libnatpmp-20110715/Makefile
+@@ -33,7 +32,7 @@
+
+ HEADERS = natpmp.h
+
+-EXECUTABLES = testgetgateway natpmpc-shared natpmpc-static
++EXECUTABLES = testgetgateway natpmpc-shared
+
+ INSTALLPREFIX ?= $(PREFIX)/usr
+ INSTALLDIRINC = $(INSTALLPREFIX)/include
+@@ -45,9 +44,9 @@
+
+ .PHONY: all clean depend install cleaninstall installpythonmodule
+
+-all: $(STATICLIB) $(SHAREDLIB) $(EXECUTABLES)
++all: $(SHAREDLIB) $(EXECUTABLES)
+
+-pythonmodule: $(STATICLIB) libnatpmpmodule.c setup.py
++pythonmodule: libnatpmpmodule.c setup.py
+ python setup.py build
+ touch $@
+
+@@ -55,11 +54,10 @@
+ depend:
+ makedepend -f$(MAKEFILE_LIST) -Y $(OBJS:.o=.c) 2>/dev/null
+
+-install: $(HEADERS) $(STATICLIB) $(SHAREDLIB) natpmpc-shared
++install: $(HEADERS) $(SHAREDLIB) natpmpc-shared
+ $(INSTALL) -d $(INSTALLDIRINC)
+ $(INSTALL) -m 644 $(HEADERS) $(INSTALLDIRINC)
+ $(INSTALL) -d $(INSTALLDIRLIB)
+- $(INSTALL) -m 644 $(STATICLIB) $(INSTALLDIRLIB)
+ $(INSTALL) -m 644 $(SHAREDLIB) $(INSTALLDIRLIB)/$(SONAME)
+ $(INSTALL) -d $(INSTALLDIRBIN)
+ $(INSTALL) -m 755 natpmpc-shared $(INSTALLDIRBIN)/natpmpc
+@@ -76,7 +74,6 @@
+ $(RM) $(addprefix $(INSTALLDIRINC), $(HEADERS))
+ $(RM) $(INSTALLDIRLIB)/$(SONAME)
+ $(RM) $(INSTALLDIRLIB)/$(SHAREDLIB)
+- $(RM) $(INSTALLDIRLIB)/$(STATICLIB)
+
+ testgetgateway: testgetgateway.o getgateway.o
+
diff --git a/net-libs/libnatpmp/files/respect-FLAGS-20130911.patch b/net-libs/libnatpmp/files/respect-FLAGS-20130911.patch
new file mode 100644
index 000000000000..df36e2d4a4a0
--- /dev/null
+++ b/net-libs/libnatpmp/files/respect-FLAGS-20130911.patch
@@ -0,0 +1,53 @@
+diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
+--- libnatpmp-20130911.orig/Makefile 2013-09-10 16:15:06.000000000 -0400
++++ libnatpmp-20130911/Makefile 2013-09-12 13:20:29.191447842 -0400
+@@ -5,7 +5,7 @@
+ # http://miniupnp.free.fr/libnatpmp.html
+
+ OS = $(shell uname -s)
+-CC = gcc
++CC ?= gcc
+ INSTALL = install
+ VERSION = $(shell cat VERSION)
+
+@@ -22,6 +22,7 @@
+ # APIVERSION is used in soname
+ APIVERSION = 1
+ #LDFLAGS = -Wl,--no-undefined
++GENTOO_CFLAGS := $(CFLAGS)
+ CFLAGS = -Os
+ #CFLAGS = -g -O0
+ CFLAGS += -fPIC
+@@ -52,6 +53,8 @@
+ endif
+ endif
+
++CFLAGS := $(CFLAGS) $(GENTOO_CFLAGS)
++
+ HEADERS = natpmp.h
+
+ EXECUTABLES = testgetgateway natpmpc-shared natpmpc-static
+@@ -144,19 +147,19 @@
+ $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ natpmpc-static: natpmpc.o $(STATICLIB)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ natpmpc-shared: natpmpc.o $(SHAREDLIB)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ $(STATICLIB): $(LIBOBJS)
+ $(AR) crs $@ $?
+
+ $(SHAREDLIB): $(LIBOBJS)
+ ifeq ($(OS), Darwin)
+- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+ else
+- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
+ endif
+
+
diff --git a/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch b/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
new file mode 100644
index 000000000000..0a007b169a79
--- /dev/null
+++ b/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
@@ -0,0 +1,36 @@
+diff -Naur libnatpmp-20140401.orig/Makefile libnatpmp-20140401/Makefile
+--- libnatpmp-20140401.orig/Makefile 2013-12-09 15:52:28.000000000 -0500
++++ libnatpmp-20140401/Makefile 2014-04-02 10:03:42.128609226 -0400
+@@ -5,7 +5,7 @@
+ # http://miniupnp.free.fr/libnatpmp.html
+
+ OS = $(shell uname -s)
+-CC = gcc
++CC ?= gcc
+ INSTALL = install -p
+ ARCH = $(shell uname -m | sed -e s/i.86/i686/)
+ VERSION = $(shell cat VERSION)
+@@ -153,19 +153,19 @@
+ $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ natpmpc-static: natpmpc.o $(STATICLIB)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ natpmpc-shared: natpmpc.o $(SHAREDLIB)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ $(STATICLIB): $(LIBOBJS)
+ $(AR) crs $@ $?
+
+ $(SHAREDLIB): $(LIBOBJS)
+ ifeq ($(OS), Darwin)
+- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+ else
+- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
+ endif
+
+
diff --git a/net-libs/libnatpmp/files/respect-FLAGS.patch b/net-libs/libnatpmp/files/respect-FLAGS.patch
new file mode 100644
index 000000000000..0338d1810e67
--- /dev/null
+++ b/net-libs/libnatpmp/files/respect-FLAGS.patch
@@ -0,0 +1,40 @@
+--- libnatpmp-20110808/Makefile
++++ libnatpmp-20110808/Makefile
+@@ -4,13 +4,12 @@
+ # http://miniupnp.free.fr/libnatpmp.html
+
+ OS = $(shell uname -s)
+-CC = gcc
++CC ?= gcc
+ INSTALL = install
+
+ # APIVERSION is used in soname
+ APIVERSION = 1
+-#LDFLAGS = -Wl,--no-undefined
+-CFLAGS = -O -fPIC -Wall -DENABLE_STRNATPMPERR
++CFLAGS := -Wall -DENABLE_STRNATPMPERR $(CFLAGS)
+
+ LIBOBJS = natpmp.o getgateway.o
+
+@@ -75,16 +75,18 @@
+ testgetgateway: testgetgateway.o getgateway.o
+
+ natpmpc-shared: natpmpc.o $(SHAREDLIB)
+- $(CC) $(LDFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
++
++getgateway.o natpmp.o: CFLAGS += -fPIC
+
+ $(STATICLIB): $(LIBOBJS)
+ $(AR) crs $@ $?
+
+ $(SHAREDLIB): $(LIBOBJS)
+ ifeq ($(OS), Darwin)
+- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+ else
+- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^
+ endif
+
+ # DO NOT DELETE
diff --git a/net-libs/libnatpmp/files/respect-libdir-20120821.patch b/net-libs/libnatpmp/files/respect-libdir-20120821.patch
new file mode 100644
index 000000000000..90b7167a1d4f
--- /dev/null
+++ b/net-libs/libnatpmp/files/respect-libdir-20120821.patch
@@ -0,0 +1,20 @@
+diff -Naur libnatpmp-20120821.orig/Makefile libnatpmp-20120821/Makefile
+--- libnatpmp-20120821.orig/Makefile 2012-08-26 20:26:27.000000000 -0400
++++ libnatpmp-20120821/Makefile 2012-08-26 20:27:07.000000000 -0400
+@@ -4,6 +4,7 @@
+ # (c) 2007-2011 Thomas Bernard
+ # http://miniupnp.free.fr/libnatpmp.html
+
++GENTOO_LIBDIR ?= lib
+ OS = $(shell uname -s)
+ CC ?= gcc
+ INSTALL = install
+@@ -41,7 +42,7 @@
+
+ INSTALLPREFIX ?= $(PREFIX)/usr
+ INSTALLDIRINC = $(INSTALLPREFIX)/include
+-INSTALLDIRLIB = $(INSTALLPREFIX)/lib
++INSTALLDIRLIB = $(INSTALLPREFIX)/$(GENTOO_LIBDIR)
+ INSTALLDIRBIN = $(INSTALLPREFIX)/bin
+
+ .PHONY: all clean depend install cleaninstall installpythonmodule
diff --git a/net-libs/libnatpmp/files/respect-libdir.patch b/net-libs/libnatpmp/files/respect-libdir.patch
new file mode 100644
index 000000000000..07f5d87ddf98
--- /dev/null
+++ b/net-libs/libnatpmp/files/respect-libdir.patch
@@ -0,0 +1,19 @@
+--- libnatpmp-20110808/Makefile
++++ libnatpmp-20110808/Makefile
+@@ -6,6 +6,7 @@
+ # (c) 2007-2011 Thomas Bernard
+ # http://miniupnp.free.fr/libnatpmp.html
+
++GENTOO_LIBDIR ?= lib
+ OS = $(shell uname -s)
+ CC ?= gcc
+ INSTALL = install
+@@ -36,7 +37,7 @@
+
+ INSTALLPREFIX ?= $(PREFIX)/usr
+ INSTALLDIRINC = $(INSTALLPREFIX)/include
+-INSTALLDIRLIB = $(INSTALLPREFIX)/lib
++INSTALLDIRLIB = $(INSTALLPREFIX)/$(GENTOO_LIBDIR)
+ INSTALLDIRBIN = $(INSTALLPREFIX)/bin
+
+ .PHONY: all clean depend install cleaninstall installpythonmodule