summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-11 12:58:49 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-11 12:58:49 +0100
commitadeb4e0c6e7903a8fb1f07f7caee0cb7e84ddd84 (patch)
tree94988cdc82799368aa582a6c91a8ebc95a4199f0 /net-libs/libnatpmp/files
parentdev-libs/unibilium: arm stable wrt bug #702366 (diff)
downloadgentoo-adeb4e0c6e7903a8fb1f07f7caee0cb7e84ddd84.tar.gz
gentoo-adeb4e0c6e7903a8fb1f07f7caee0cb7e84ddd84.tar.bz2
gentoo-adeb4e0c6e7903a8fb1f07f7caee0cb7e84ddd84.zip
net-libs/libnatpmp: Clean up patches
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/libnatpmp/files')
-rw-r--r--net-libs/libnatpmp/files/libnatpmp-20150609-gentoo.patch (renamed from net-libs/libnatpmp/files/remove-static-lib-20130911.patch)49
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS-20140401.patch36
-rw-r--r--net-libs/libnatpmp/files/respect-libdir-20120821.patch20
3 files changed, 36 insertions, 69 deletions
diff --git a/net-libs/libnatpmp/files/remove-static-lib-20130911.patch b/net-libs/libnatpmp/files/libnatpmp-20150609-gentoo.patch
index a2c1f516c363..41593a041582 100644
--- a/net-libs/libnatpmp/files/remove-static-lib-20130911.patch
+++ b/net-libs/libnatpmp/files/libnatpmp-20150609-gentoo.patch
@@ -1,7 +1,17 @@
-diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
---- libnatpmp-20130911.orig/Makefile 2013-09-13 07:00:55.874343916 -0400
-+++ libnatpmp-20130911/Makefile 2013-09-13 07:03:33.733351101 -0400
-@@ -35,7 +35,6 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,8 +4,9 @@
+ # (c) 2007-2013 Thomas Bernard
+ # http://miniupnp.free.fr/libnatpmp.html
+
++GENTOO_LIBDIR ?= lib
+ OS = $(shell uname -s)
+-CC = gcc
++CC ?= gcc
+ INSTALL = install -p
+ ARCH = $(shell uname -m | sed -e s/i.86/i686/)
+ VERSION = $(shell cat VERSION)
+@@ -35,7 +36,6 @@
OBJS = $(LIBOBJS) testgetgateway.o natpmpc.o natpmp-jni.o
@@ -9,7 +19,7 @@ diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
ifeq ($(OS), Darwin)
SHAREDLIB = libnatpmp.dylib
JNISHAREDLIB = libjninatpmp.dylib
-@@ -58,7 +57,7 @@
+@@ -58,11 +58,11 @@
HEADERS = natpmp.h
@@ -18,7 +28,12 @@ diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
INSTALLPREFIX ?= $(PREFIX)/usr
INSTALLDIRINC = $(INSTALLPREFIX)/include
-@@ -72,9 +71,9 @@
+-INSTALLDIRLIB = $(INSTALLPREFIX)/lib
++INSTALLDIRLIB = $(INSTALLPREFIX)/$(GENTOO_LIBDIR)
+ INSTALLDIRBIN = $(INSTALLPREFIX)/bin
+
+ JAVA ?= java
+@@ -74,9 +74,9 @@
.PHONY: all clean depend install cleaninstall installpythonmodule
@@ -30,7 +45,7 @@ diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
python setup.py build
touch $@
-@@ -82,18 +81,17 @@
+@@ -84,18 +84,17 @@
python setup.py install
clean:
@@ -51,7 +66,7 @@ diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
$(INSTALL) -m 644 $(SHAREDLIB) $(INSTALLDIRLIB)/$(SONAME)
$(INSTALL) -d $(INSTALLDIRBIN)
$(INSTALL) -m 755 natpmpc-shared $(INSTALLDIRBIN)/natpmpc
-@@ -142,20 +140,13 @@
+@@ -147,25 +146,18 @@
$(RM) $(addprefix $(INSTALLDIRINC), $(HEADERS))
$(RM) $(INSTALLDIRLIB)/$(SONAME)
$(RM) $(INSTALLDIRLIB)/$(SHAREDLIB)
@@ -61,14 +76,22 @@ diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
$(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-natpmpc-static: natpmpc.o $(STATICLIB)
-- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
natpmpc-shared: natpmpc.o $(SHAREDLIB)
- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+-
-$(STATICLIB): $(LIBOBJS)
- $(AR) crs $@ $?
--
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
$(SHAREDLIB): $(LIBOBJS)
ifeq ($(OS), Darwin)
- $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+ else
+- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
+ endif
+
+
diff --git a/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch b/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
deleted file mode 100644
index 0a007b169a79..000000000000
--- a/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naur libnatpmp-20140401.orig/Makefile libnatpmp-20140401/Makefile
---- libnatpmp-20140401.orig/Makefile 2013-12-09 15:52:28.000000000 -0500
-+++ libnatpmp-20140401/Makefile 2014-04-02 10:03:42.128609226 -0400
-@@ -5,7 +5,7 @@
- # http://miniupnp.free.fr/libnatpmp.html
-
- OS = $(shell uname -s)
--CC = gcc
-+CC ?= gcc
- INSTALL = install -p
- ARCH = $(shell uname -m | sed -e s/i.86/i686/)
- VERSION = $(shell cat VERSION)
-@@ -153,19 +153,19 @@
- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
- natpmpc-static: natpmpc.o $(STATICLIB)
-- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
- natpmpc-shared: natpmpc.o $(SHAREDLIB)
-- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
- $(STATICLIB): $(LIBOBJS)
- $(AR) crs $@ $?
-
- $(SHAREDLIB): $(LIBOBJS)
- ifeq ($(OS), Darwin)
-- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
-+ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
- else
-- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
- endif
-
-
diff --git a/net-libs/libnatpmp/files/respect-libdir-20120821.patch b/net-libs/libnatpmp/files/respect-libdir-20120821.patch
deleted file mode 100644
index 90b7167a1d4f..000000000000
--- a/net-libs/libnatpmp/files/respect-libdir-20120821.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -Naur libnatpmp-20120821.orig/Makefile libnatpmp-20120821/Makefile
---- libnatpmp-20120821.orig/Makefile 2012-08-26 20:26:27.000000000 -0400
-+++ libnatpmp-20120821/Makefile 2012-08-26 20:27:07.000000000 -0400
-@@ -4,6 +4,7 @@
- # (c) 2007-2011 Thomas Bernard
- # http://miniupnp.free.fr/libnatpmp.html
-
-+GENTOO_LIBDIR ?= lib
- OS = $(shell uname -s)
- CC ?= gcc
- INSTALL = install
-@@ -41,7 +42,7 @@
-
- INSTALLPREFIX ?= $(PREFIX)/usr
- INSTALLDIRINC = $(INSTALLPREFIX)/include
--INSTALLDIRLIB = $(INSTALLPREFIX)/lib
-+INSTALLDIRLIB = $(INSTALLPREFIX)/$(GENTOO_LIBDIR)
- INSTALLDIRBIN = $(INSTALLPREFIX)/bin
-
- .PHONY: all clean depend install cleaninstall installpythonmodule