summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-16 22:43:02 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-16 22:57:38 +0200
commitab5d0e6bbd010a4e6a569abd29b3c3f8955844bc (patch)
tree8c066f349f23f9c05c94cd2fd2ec43cce080980d /net-libs/libnet/libnet-1.2.ebuild
parentapp-text/openjade: stable 1.3.2-r9 for hppa, bug #697528 (diff)
downloadgentoo-ab5d0e6bbd010a4e6a569abd29b3c3f8955844bc.tar.gz
gentoo-ab5d0e6bbd010a4e6a569abd29b3c3f8955844bc.tar.bz2
gentoo-ab5d0e6bbd010a4e6a569abd29b3c3f8955844bc.zip
net-libs/libnet: Version 1.2
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/libnet/libnet-1.2.ebuild')
-rw-r--r--net-libs/libnet/libnet-1.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/libnet/libnet-1.2.ebuild b/net-libs/libnet/libnet-1.2.ebuild
new file mode 100644
index 000000000000..1fd8b0b6e396
--- /dev/null
+++ b/net-libs/libnet/libnet-1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="library providing an API for commonly used low-level network functions"
+HOMEPAGE="http://libnet-dev.sourceforge.net/ https://github.com/libnet/libnet"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD BSD-2 HPND"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs"
+
+DOCS=(
+ ChangeLog.md README.md doc/MIGRATION.md
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}