summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-15 14:04:44 +0100
committerSam James <sam@gentoo.org>2023-07-15 14:17:54 +0100
commitd136783e783c7b81e1eac0464bec4e52abcc80aa (patch)
tree6c8bae10bc76b52ec11fa3a2a639c1d96d2d1b12 /net-libs/libnftnl/libnftnl-1.2.6.ebuild
parentdev-java/cache2k-api: Stabilize 0.23.1 amd64, #910387 (diff)
downloadgentoo-d136783e783c7b81e1eac0464bec4e52abcc80aa.tar.gz
gentoo-d136783e783c7b81e1eac0464bec4e52abcc80aa.tar.bz2
gentoo-d136783e783c7b81e1eac0464bec4e52abcc80aa.zip
net-libs/libnftnl: add 1.2.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libnftnl/libnftnl-1.2.6.ebuild')
-rw-r--r--net-libs/libnftnl/libnftnl-1.2.6.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/net-libs/libnftnl/libnftnl-1.2.6.ebuild b/net-libs/libnftnl/libnftnl-1.2.6.ebuild
new file mode 100644
index 000000000000..2515991d1a98
--- /dev/null
+++ b/net-libs/libnftnl/libnftnl-1.2.6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/netfilter.org.asc
+inherit linux-info usr-ldscript verify-sig
+
+DESCRIPTION="Netlink API to the in-kernel nf_tables subsystem"
+HOMEPAGE="https://netfilter.org/projects/nftables/"
+
+if [[ ${PV} =~ ^[9]{4,}$ ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://git.netfilter.org/${PN}"
+else
+ SRC_URI="
+ https://netfilter.org/projects/${PN}/files/${P}.tar.xz
+ verify-sig? ( https://netfilter.org/projects/${PN}/files/${P}.tar.xz.sig )
+ "
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+ BDEPEND+="verify-sig? ( sec-keys/openpgp-keys-netfilter )"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/11" # libnftnl.so version
+IUSE="examples static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=net-libs/libmnl-1.0.4:=
+"
+BDEPEND+="
+ virtual/pkgconfig
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if kernel_is ge 3 13; then
+ CONFIG_CHECK="~NF_TABLES"
+ linux-info_pkg_setup
+ else
+ eerror "This package requires kernel version 3.13 or newer to work properly."
+ fi
+}
+
+src_prepare() {
+ default
+
+ [[ ${PV} =~ ^[9]{4,}$ ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ gen_usr_ldscript -a nftnl
+
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ if use examples; then
+ find examples/ -name 'Makefile*' -delete || die "Could not rm examples"
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}