summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-11-19 10:14:35 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-11-19 10:18:25 -0800
commitd67a8a0202e7db2e124d3adacdb761d275d38046 (patch)
treedaff0020715d029b1d86bd8b5e8a5508f0749d76 /net-libs/libnftnl
parentdev-lua/luasec: Stabilize 1.0.2-r1 x86, #824602 (diff)
downloadgentoo-d67a8a0202e7db2e124d3adacdb761d275d38046.tar.gz
gentoo-d67a8a0202e7db2e124d3adacdb761d275d38046.tar.bz2
gentoo-d67a8a0202e7db2e124d3adacdb761d275d38046.zip
net-libs/libnftnl: Version bump to 1.2.1
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-libs/libnftnl')
-rw-r--r--net-libs/libnftnl/Manifest1
-rw-r--r--net-libs/libnftnl/libnftnl-1.2.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/libnftnl/Manifest b/net-libs/libnftnl/Manifest
index a8ec193e233b..492e21041f0b 100644
--- a/net-libs/libnftnl/Manifest
+++ b/net-libs/libnftnl/Manifest
@@ -1 +1,2 @@
DIST libnftnl-1.2.0.tar.bz2 388751 BLAKE2B 6f61e7af8e50577029b1cf5ba7260f3803a64c410c7d35be8bbf3b6f9445d9db3be367442f56fb81f3ed49bc3efeab8dd2ed51bab4a1e4427f552d48e4bb559a SHA512 2a068e7eab308442bbfba5325f3aebeb874c142b029ff5906cadf63a1f879b20930bc55cd9554c5d256a0642f0f5a6d36177d9ae88cf507ab5dfc7fabffbb380
+DIST libnftnl-1.2.1.tar.bz2 395299 BLAKE2B 9f525eb540ed959075199aab4b4217bdcf0f67d6744e58d7eab9f7a50aca2d22c6d65419b15c98d24772ef020c3ed2662eba7a0812a5919a840cee5aa589b056 SHA512 cabe6896210c451d7917d1abde5e73a65594d53f011486f75dd7be5b4804c49d10f0e508675e091e1faf0363b82670b3f3a167a85db91d52742dc69445888b6a
diff --git a/net-libs/libnftnl/libnftnl-1.2.1.ebuild b/net-libs/libnftnl/libnftnl-1.2.1.ebuild
new file mode 100644
index 000000000000..75e1ab39a6c8
--- /dev/null
+++ b/net-libs/libnftnl/libnftnl-1.2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info usr-ldscript
+
+DESCRIPTION="Netlink API to the in-kernel nf_tables subsystem"
+HOMEPAGE="https://netfilter.org/projects/nftables/"
+
+if [[ ${PV} =~ ^[9]{4,}$ ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.netfilter.org/${PN}"
+else
+ SRC_URI="https://netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/11" # libnftnl.so version
+IUSE="examples static-libs test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=net-libs/libmnl-1.0.4:="
+BDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if kernel_is ge 3 13; then
+ CONFIG_CHECK="~NF_TABLES"
+ linux-info_pkg_setup
+ else
+ eerror "This package requires kernel version 3.13 or newer to work properly."
+ fi
+}
+
+src_prepare() {
+ default
+ [[ ${PV} =~ ^[9]{4,}$ ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a nftnl
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ if use examples; then
+ find examples/ -name 'Makefile*' -delete || die "Could not rm examples"
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}