summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-02-23 21:10:27 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-02-23 21:10:37 +1100
commite0d494609a4d9212c5894c8959ae81347945cc52 (patch)
tree1e54dc5a3843f0fedbb1fbabcac4f281a4800fdb /net-libs/libproxy/files
parentnet-misc/curl: arm stable (bug 610572). (diff)
downloadgentoo-e0d494609a4d9212c5894c8959ae81347945cc52.tar.gz
gentoo-e0d494609a4d9212c5894c8959ae81347945cc52.tar.bz2
gentoo-e0d494609a4d9212c5894c8959ae81347945cc52.zip
net-libs/libproxy: backport patch from upstream solving build failure with USE="mono"
Gentoo-bug: 600254 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-libs/libproxy/files')
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.13-cmake-37.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/libproxy/files/libproxy-0.4.13-cmake-37.patch b/net-libs/libproxy/files/libproxy-0.4.13-cmake-37.patch
new file mode 100644
index 000000000000..d96879a7cba6
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.4.13-cmake-37.patch
@@ -0,0 +1,27 @@
+From 72bda7188408bd3c2491ea664da294cc483220bc Mon Sep 17 00:00:00 2001
+From: Andrey Rakhmatullin <wrar@wrar.name>
+Date: Sun, 20 Nov 2016 18:40:49 +0500
+Subject: [PATCH] Set CMP0054 CMake policy to NEW.
+
+CMake 3.7 exports a "t" variable for all projects and because of that
+the elseif statement in cmake/CMakeCSharpInformation.cmake:311 works
+incorrectly if CMP0054 is not set to NEW (as "t" is expanded to the
+variable value).
+---
+ CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5313787..451e7a6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,6 +3,9 @@ cmake_minimum_required(VERSION 2.6)
+ if(POLICY CMP0011)
+ cmake_policy(SET CMP0011 NEW)
+ endif(POLICY CMP0011)
++if(POLICY CMP0054)
++ cmake_policy(SET CMP0054 NEW)
++endif(POLICY CMP0054)
+
+ # Make sure we look in our cmake folder for additional definitions
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake )