summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-13 20:21:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-13 20:26:34 +0100
commit001b200d2bc7ca12a9d3239d00a1bcae07465db9 (patch)
tree20c7f5f5623ccef4455ea4a8a86158c698276ad9 /net-libs/libproxy
parentnet-libs/libproxy: 0.4.15 version bump, EAPI-7 bump, python3 support (diff)
downloadgentoo-001b200d2bc7ca12a9d3239d00a1bcae07465db9.tar.gz
gentoo-001b200d2bc7ca12a9d3239d00a1bcae07465db9.tar.bz2
gentoo-001b200d2bc7ca12a9d3239d00a1bcae07465db9.zip
net-libs/libproxy: Drop USE python, python3 has a major runtime issue
Bug: https://bugs.gentoo.org/608886 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libproxy')
-rw-r--r--net-libs/libproxy/libproxy-0.4.15.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/net-libs/libproxy/libproxy-0.4.15.ebuild b/net-libs/libproxy/libproxy-0.4.15.ebuild
index 0e4f53791881..8f8f6a2ec5a1 100644
--- a/net-libs/libproxy/libproxy-0.4.15.ebuild
+++ b/net-libs/libproxy/libproxy-0.4.15.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_ECLASS=cmake
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-multilib flag-o-matic mono-env python-r1
+inherit cmake-multilib flag-o-matic mono-env
DESCRIPTION="Library for automatic proxy configuration management"
HOMEPAGE="https://github.com/libproxy/libproxy"
@@ -14,9 +13,8 @@ SRC_URI="https://github.com/libproxy/libproxy/archive/${PV}.tar.gz -> ${P}.tar.g
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="gnome kde mono networkmanager perl python spidermonkey test webkit"
+IUSE="gnome kde mono networkmanager perl spidermonkey test webkit"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
BDEPEND="
@@ -27,7 +25,6 @@ DEPEND="
mono? ( dev-lang/mono )
networkmanager? ( sys-apps/dbus:0[${MULTILIB_USEDEP}] )
perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
spidermonkey? ( >=dev-lang/spidermonkey-52.0.0:= )
webkit? ( net-libs/webkit-gtk:4 )
"
@@ -71,7 +68,7 @@ multilib_src_configure() {
-DWITH_NM=$(usex networkmanager)
$(multilib_is_native_abi && usex perl -DPERL_VENDORINSTALL=ON)
-DWITH_PERL=$(multilib_is_native_abi && usex perl || echo OFF)
- -DWITH_PYTHON3=$(multilib_is_native_abi && usex python || echo OFF)
+ -DWITH_PYTHON3=OFF # Major issue: https://github.com/libproxy/libproxy/issues/65
-DWITH_MOZJS=$(multilib_is_native_abi && usex spidermonkey || echo OFF)
-DBUILD_TESTING=$(usex test)
-DWITH_WEBKIT3=$(multilib_is_native_abi && usex webkit || echo OFF)
@@ -82,11 +79,9 @@ multilib_src_configure() {
src_configure() {
[[ ${CHOST} == *-solaris* ]] && append-libs -lsocket -lnsl
- use python && python_setup
multilib-minimal_src_configure
}
multilib_src_install_all() {
doman "${FILESDIR}"/proxy.1
- use python && python_foreach_impl python_domodule bindings/python/libproxy.py
}