summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-14 02:15:08 +0000
committerSam James <sam@gentoo.org>2024-01-14 02:15:49 +0000
commit005a5d672e1a59f2d99c7aa0e66402866f754be4 (patch)
tree5791a7503a870d1b4caea670e4b5d644cd45cbab /net-libs/libpsl
parentsys-libs/zlib-ng: add 2.1.6 (diff)
downloadgentoo-005a5d672e1a59f2d99c7aa0e66402866f754be4.tar.gz
gentoo-005a5d672e1a59f2d99c7aa0e66402866f754be4.tar.bz2
gentoo-005a5d672e1a59f2d99c7aa0e66402866f754be4.zip
net-libs/libpsl: add 0.21.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libpsl')
-rw-r--r--net-libs/libpsl/Manifest1
-rw-r--r--net-libs/libpsl/libpsl-0.21.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/libpsl/Manifest b/net-libs/libpsl/Manifest
index 57e9e2cf8157..400b330da1df 100644
--- a/net-libs/libpsl/Manifest
+++ b/net-libs/libpsl/Manifest
@@ -1 +1,2 @@
DIST libpsl-0.21.2.tar.gz 7617025 BLAKE2B b50f805bb467dc3284bc91645a37a2208098ad809d3771c74ef13c3b8f6029a07ad80a56702c7e3d1a1125d272403c85dd97b64a28465b9ff2d095eaf94b9a4d SHA512 f1df72220bf4391d4701007100b0df66c833a2cbcb7481c9d13f0b9e0cad3b66d2d15d4b976e5bad60d2ad1540355112fa1acb07aa925c241d2d7cd20681c71d
+DIST libpsl-0.21.5.tar.gz 7624251 BLAKE2B a0076f622b85df99f866de6707850ac216b764bdb68c6d516f4603da42dac8eae3ee4c53d68dbb6af6f779c2c7f1b9caab74c8b558209b1f6823f95c13fc3ceb SHA512 c14d575cecc0f1693894dd79565b6b9220084ddfa43b908a1cefe16d147cdd5ec47796eb0c2135e2f829a951abaf39d8a371ab5c1352f57b36e610e25adf91f5
diff --git a/net-libs/libpsl/libpsl-0.21.5.ebuild b/net-libs/libpsl/libpsl-0.21.5.ebuild
new file mode 100644
index 000000000000..dc56355321fb
--- /dev/null
+++ b/net-libs/libpsl/libpsl-0.21.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit meson-multilib python-any-r1
+
+DESCRIPTION="C library for the Public Suffix List"
+HOMEPAGE="https://github.com/rockdaboot/libpsl"
+SRC_URI="https://github.com/rockdaboot/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="icu +idn test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ icu? ( !idn? ( dev-libs/icu:=[${MULTILIB_USEDEP}] ) )
+ idn? (
+ dev-libs/libunistring:=[${MULTILIB_USEDEP}]
+ net-dns/libidn2:=[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_pretend() {
+ if use icu && use idn ; then
+ ewarn "\"icu\" and \"idn\" USE flags are enabled. Using \"idn\"."
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+
+ # Prefer idn even if icu is in USE as well
+ if use idn ; then
+ emesonargs+=(
+ -Druntime=libidn2
+ -Dbuiltin=true
+ )
+ elif use icu ; then
+ emesonargs+=(
+ -Druntime=libicu
+ -Dbuiltin=true
+ )
+ else
+ emesonargs+=(
+ -Druntime=no
+ )
+ fi
+
+ meson_src_configure
+}