summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-15 09:50:22 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-15 09:54:51 -0700
commit1255212900cc66d4865ce9a331bdaad96f50393f (patch)
treeabfcd2933387ca74f9de4a046b85cfde459990da /net-libs/libqmi
parentgnome-extra/gnome-shell-extensions: Version bump to 40.1 (diff)
downloadgentoo-1255212900cc66d4865ce9a331bdaad96f50393f.tar.gz
gentoo-1255212900cc66d4865ce9a331bdaad96f50393f.tar.bz2
gentoo-1255212900cc66d4865ce9a331bdaad96f50393f.zip
net-libs/libqmi: Version bump to 1.28.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/libqmi')
-rw-r--r--net-libs/libqmi/Manifest1
-rw-r--r--net-libs/libqmi/libqmi-1.28.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libqmi/Manifest b/net-libs/libqmi/Manifest
index f84cb55048b5..e03fe5e87193 100644
--- a/net-libs/libqmi/Manifest
+++ b/net-libs/libqmi/Manifest
@@ -1,2 +1,3 @@
DIST libqmi-1.26.6.tar.xz 1127552 BLAKE2B 1dba56c867c688c991fde7bb019234a05d77092f0725498d677a7ff620c56e58e17c873c773d96ee2131bfeac8cdbec86dadacd8fcc2f751f4e9a8d2c75efe5b SHA512 6c5e05fc158a085e1f652ff31cef65762c026cb09eb630153fddccb15e19187141e74c79818ebe00a058c5624891981cfce4d56545d4150ebb3b6e8d7bddb5ba
DIST libqmi-1.28.2.tar.xz 1165204 BLAKE2B 17f7462d84b74099a5ef4fa6f28e777a4587be0a7652b38c4ab5c0f50bbbbd0b8b293df22d7a8c470444df23fd405e3b176e8c449019787c5305fef13d0b27b2 SHA512 10d11b780aa381e93669aad2540c609bcd3f789302ed76d80b9845a24f84d8741b8c39287a2007ec80d8e0e517686023d08a7a677426c77f3b12ec172edc05e7
+DIST libqmi-1.28.4.tar.xz 1168088 BLAKE2B 828a8688a49a08f0848414b8e51c2ece4a0035ecdf449a5dc9e2cf3b6ecaf1525d5a1c29e329a584ec054f66b9a141d0ba3980b8affb34db3088ed2b5591a265 SHA512 dad3cd2740804d2ec6aa04f0f140d385c00d5a3854d75ccdf54ee6fa4f3cdfc02de5da21cd8b43d5a7c6b467b94b5001bc857fbab01aeedbdb51c0e3d9da9690
diff --git a/net-libs/libqmi/libqmi-1.28.4.ebuild b/net-libs/libqmi/libqmi-1.28.4.ebuild
new file mode 100644
index 000000000000..ae2df1d55498
--- /dev/null
+++ b/net-libs/libqmi/libqmi-1.28.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mobile-broadband/libqmi.git"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+ SRC_URI="https://www.freedesktop.org/software/libqmi/${P}.tar.xz"
+fi
+
+DESCRIPTION="Qualcomm MSM (Mobile Station Modem) Interface (QMI) modem protocol library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libqmi/ https://gitlab.freedesktop.org/mobile-broadband/libqmi"
+
+LICENSE="LGPL-2"
+SLOT="0/5.7" # soname of libqmi-glib.so
+IUSE="gtk-doc +mbim"
+
+RDEPEND=">=dev-libs/glib-2.48
+ dev-libs/libgudev
+ mbim? ( >=net-libs/libmbim-1.18.0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )"
+[[ ${PV} == "9999" ]] && BDEPEND+=" dev-util/gtk-doc" #469214
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-Werror
+ --disable-static
+ --disable-qrtr # libqrtr-glib not packaged
+ $(use_enable mbim mbim-qmux)
+ $(use_enable gtk-doc)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}