summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-10 20:48:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-10 21:00:07 +0100
commit3e43ab75d413bd87e2cf060fb5998e3e27567cf4 (patch)
tree58bb0e9729608690ad49a7112dc6a20542e36d8e /net-libs/libquotient/libquotient-0.7.1.ebuild
parentdev-qt/qtdeclarative: Revert "Bump to QT5_KDEPATCHSET_REV=2" (diff)
downloadgentoo-3e43ab75d413bd87e2cf060fb5998e3e27567cf4.tar.gz
gentoo-3e43ab75d413bd87e2cf060fb5998e3e27567cf4.tar.bz2
gentoo-3e43ab75d413bd87e2cf060fb5998e3e27567cf4.zip
net-libs/libquotient: add 0.7.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libquotient/libquotient-0.7.1.ebuild')
-rw-r--r--net-libs/libquotient/libquotient-0.7.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libquotient/libquotient-0.7.1.ebuild b/net-libs/libquotient/libquotient-0.7.1.ebuild
new file mode 100644
index 000000000000..4a30091b1f75
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ dev-libs/qtkeychain:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.7.0-no-android.patch
+ "${FILESDIR}"/${PN}-0.7.0-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DBUILD_TESTING=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ )
+ cmake_src_configure
+}