summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-22 23:44:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-22 23:59:11 +0200
commit893bcaa4fea108ce2e6240aa1009c2bf75ec9bf3 (patch)
tree367673d2ad5bbab7ed714f8f25465b7da3ead9e1 /net-libs/libquotient
parentsys-apps/xdg-desktop-portal: 1.10.1 version bump (diff)
downloadgentoo-893bcaa4fea108ce2e6240aa1009c2bf75ec9bf3.tar.gz
gentoo-893bcaa4fea108ce2e6240aa1009c2bf75ec9bf3.tar.bz2
gentoo-893bcaa4fea108ce2e6240aa1009c2bf75ec9bf3.zip
net-libs/libquotient: 0.6.9 version bump
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libquotient')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.6.9.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index 912dfde90805..5cefc5a58394 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1,2 +1,3 @@
DIST libquotient-0.6.7.tar.gz 560174 BLAKE2B 1f0fe371bf84925c7a8b7728a1e484e9cb7c7d5887539c86a863d05d34727b2385425743260c7c0b33205473215475c7bd5ec8b709032a00591dbfd7cafa721c SHA512 7f7c56ef5f775d38a0bd9f112f2fb7473d42d1e886d17e84d4be1afda146999658eea8691c38071fd87aec7ece52b97bc837cc98452cc698cf152003474193f2
DIST libquotient-0.6.8.tar.gz 561552 BLAKE2B b1be7c961a3b995b3c4aa0611161eefb35fffbc70528b86db78680c4a744c4fce296e40122b0e0ced48313f81f81311a35a19a751abdd3a41d0d8f09d28ba220 SHA512 e671049610069c9dc3624cc6471237504bcb9a388d2a7eecbf95eae2a2e9ac1e62f78cb9bb38c381510a69d00e4dc98d261c5951f41306a23065c35e157c69f6
+DIST libquotient-0.6.9.tar.gz 561579 BLAKE2B 160bf9d8a49d4d20ec8fa34aa97ea4e4ceb4b124846f7f042b099de37b742ca5dad4fa7ad8966c6b7c478c2eefe823e6da5ea5e45560ff085e6c6d0ece4d8315 SHA512 3b1e36b402dc78f002c764b738b340f000e0ff23e1bbc753d1dc617a585661529b5f17f91e6093d45c14c0826fac86c56f36c3276c5c9712a74d66731204abca
diff --git a/net-libs/libquotient/libquotient-0.6.9.ebuild b/net-libs/libquotient/libquotient-0.6.9.ebuild
new file mode 100644
index 000000000000..f18a7ff72943
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.6.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt5-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.6.3-no-android.patch
+ "${FILESDIR}"/${PN}-0.6.3-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQuotient_INSTALL_TESTS=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ -DCMAKE_DISABLE_FIND_PACKAGE_Git=ON # no thanks.
+ )
+ cmake_src_configure
+}