summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-11-17 20:42:43 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-11-17 20:42:57 +0000
commit2db886bd0f691a5e4fde1f45dd93110d734d58e5 (patch)
treeb283eb3422c243befbe92db186b829153cc9db2f /net-libs/librsync/librsync-2.0.1-r1.ebuild
parentsys-fs/zfs: Adding glibc blocker for < 0.7.0. Bug #617628 (diff)
downloadgentoo-2db886bd0f691a5e4fde1f45dd93110d734d58e5.tar.gz
gentoo-2db886bd0f691a5e4fde1f45dd93110d734d58e5.tar.bz2
gentoo-2db886bd0f691a5e4fde1f45dd93110d734d58e5.zip
net-libs/librsync: restore 0/2 subslot (lost in revbump), bug #635834
Noticed by Bernard in a rdiff-backup subslot conflict: ``` (net-libs/librsync-2.0.1:0/0::gentoo, ebuild scheduled for merge) conflicts with net-libs/librsync:0/2 required by (app-backup/rdiff-backup-1.3.3-r2:0/0::gentoo, ebuild scheduled for merge) ^^^^ ``` Reported-by: Bernard Cafarelli Bug: https://bugs.gentoo.org/635834 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-libs/librsync/librsync-2.0.1-r1.ebuild')
-rw-r--r--net-libs/librsync/librsync-2.0.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/librsync/librsync-2.0.1-r1.ebuild b/net-libs/librsync/librsync-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..6c20165834a8
--- /dev/null
+++ b/net-libs/librsync/librsync-2.0.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Remote delta-compression library"
+HOMEPAGE="http://librsync.sourcefrog.net/"
+SRC_URI="https://github.com/librsync/librsync/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+
+PATCHES=("${FILESDIR}"/${PN}-2.0.1-libdir.patch)
+
+src_configure() {
+ local mycmakeargs=(
+ -DTARGET_LIBDIR=$(get_libdir)
+ )
+
+ cmake-utils_src_configure
+}