summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-15 16:45:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-15 16:46:26 +0200
commitea131436455ae403f4db3c200940130bb92532d5 (patch)
treefbed9334944f43981af94ed3328d388cfa358130 /net-libs/libssh/libssh-9999.ebuild
parentkde-frameworks/kfilemetadata: Disable randomly broken test (diff)
downloadgentoo-ea131436455ae403f4db3c200940130bb92532d5.tar.gz
gentoo-ea131436455ae403f4db3c200940130bb92532d5.tar.bz2
gentoo-ea131436455ae403f4db3c200940130bb92532d5.zip
net-libs/libssh: Sort IUSE, drop unused eclass, switch HOMEPAGE to https
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'net-libs/libssh/libssh-9999.ebuild')
-rw-r--r--net-libs/libssh/libssh-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-libs/libssh/libssh-9999.ebuild b/net-libs/libssh/libssh-9999.ebuild
index b42c05d96e3e..193f9eb86e6f 100644
--- a/net-libs/libssh/libssh-9999.ebuild
+++ b/net-libs/libssh/libssh-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils cmake-multilib multilib git-r3
+inherit cmake-multilib git-r3
DESCRIPTION="Access a working SSH implementation by means of a library"
HOMEPAGE="http://www.libssh.org/"
@@ -12,20 +12,19 @@ EGIT_REPO_URI="git://git.libssh.org/projects/libssh.git"
LICENSE="LGPL-2.1"
KEYWORDS=""
SLOT="0"
-IUSE="debug doc examples gcrypt gssapi libressl pcap +sftp ssh1 server static-libs test zlib"
+IUSE="debug doc examples gcrypt gssapi libressl pcap server +sftp ssh1 static-libs test zlib"
# Maintainer: check IUSE-defaults at DefineOptions.cmake
RDEPEND="
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
!gcrypt? (
!libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
)
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
"
@@ -35,12 +34,13 @@ DOCS=( AUTHORS README ChangeLog )
EGIT_MIN_CLONE_TYPE=single
src_prepare() {
+ cmake-utils_src_prepare
+
# just install the examples do not compile them
sed -i \
-e '/add_subdirectory(examples)/s/^/#DONOTWANT/' \
CMakeLists.txt || die
- cmake-utils_src_prepare
}
multilib_src_configure() {