summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-10-15 21:26:36 +0200
committerJeroen Roovers <jer@gentoo.org>2020-10-15 21:27:36 +0200
commit87d1a1c7bc76c6b305cbbbe19d9df0c05ded6589 (patch)
treed1b824d0d108f9c91a76b729451a93b613ee9bca /net-libs/libssh2
parentdev-libs/libevdev: die if tests fail (diff)
downloadgentoo-87d1a1c7bc76c6b305cbbbe19d9df0c05ded6589.tar.gz
gentoo-87d1a1c7bc76c6b305cbbbe19d9df0c05ded6589.tar.bz2
gentoo-87d1a1c7bc76c6b305cbbbe19d9df0c05ded6589.zip
net-libs/libssh2: Version 1.9.0_p20200614
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/libssh2')
-rw-r--r--net-libs/libssh2/Manifest1
-rw-r--r--net-libs/libssh2/libssh2-1.9.0_p20200614.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/libssh2/Manifest b/net-libs/libssh2/Manifest
index b76adc58a3d8..c7f7bbe4ad77 100644
--- a/net-libs/libssh2/Manifest
+++ b/net-libs/libssh2/Manifest
@@ -1 +1,2 @@
DIST libssh2-1.9.0_p20190913.tar.gz 467616 BLAKE2B 2df7569aa118cf339340f32a106a547265a777af5834e0e22d18ac71946747e708c48d3125489b277b5c266d66cb35e7e224425bfc6a9b2e37e5d267fd7792b2 SHA512 0e095770b059b28aebd47a1219873bfe3b6e5775bbee5d526a7b6a287090e474ceac91c03b1b8a619a2a77916a110d8d20db22edc3cbfd1772190fb394a53f8a
+DIST libssh2-1.9.0_p20200614.tar.gz 482698 BLAKE2B a93c3e61ecba564263e5aa1c10769bd07b5d16def9e6948262e5bbe32d86ae39784b63c608ad4d8a4aa0fcb14c8b55742f90cd2856e043bea5b3d052a31dc871 SHA512 fa34c598149d28b12f5cefbee4816f30a807a1bde89faa3be469f690057cf2ea7dd1a83191b2a2cae3794e307d676efebd7a31d70d9587e42e0926f82a1ae73d
diff --git a/net-libs/libssh2/libssh2-1.9.0_p20200614.ebuild b/net-libs/libssh2/libssh2-1.9.0_p20200614.ebuild
new file mode 100644
index 000000000000..0e9aa105228b
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.9.0_p20200614.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+EGIT_COMMIT=6c7769dcc422250d14af1b06fce378b6ee009440
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="https://www.libssh2.org"
+SRC_URI="https://github.com/libssh2/libssh2/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="gcrypt libressl mbedtls zlib"
+REQUIRED_USE="?? ( gcrypt mbedtls )"
+RESTRICT="test"
+
+RDEPEND="
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ !gcrypt? (
+ mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
+ !mbedtls? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ )
+ )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.0-mansyntax_sh.patch
+)
+
+multilib_src_configure() {
+ local crypto_backend=OpenSSL
+ if use gcrypt; then
+ crypto_backend=Libgcrypt
+ elif use mbedtls; then
+ crypto_backend=mbedTLS
+ fi
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DCRYPTO_BACKEND=${crypto_backend}
+ -DENABLE_ZLIB_COMPRESSION=$(usex zlib)
+ )
+ cmake_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}