summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-03 09:48:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-03 10:48:02 +0100
commitb0632222d55eca178357c621fde6573db3a78045 (patch)
treea899169cab80954920786b0ec13adabe76754905 /net-libs/libssh2
parentapp-metrics/vault_exporter: add licenses for transitive go dependencies (diff)
downloadgentoo-b0632222d55eca178357c621fde6573db3a78045.tar.gz
gentoo-b0632222d55eca178357c621fde6573db3a78045.tar.bz2
gentoo-b0632222d55eca178357c621fde6573db3a78045.zip
net-libs/libssh2: Remove old
Bug: https://bugs.gentoo.org/699856 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/libssh2')
-rw-r--r--net-libs/libssh2/Manifest1
-rw-r--r--net-libs/libssh2/files/libssh2-1.9.0-missing.patch181
-rw-r--r--net-libs/libssh2/libssh2-1.9.0-r1.ebuild58
-rw-r--r--net-libs/libssh2/libssh2-1.9.0.ebuild57
4 files changed, 0 insertions, 297 deletions
diff --git a/net-libs/libssh2/Manifest b/net-libs/libssh2/Manifest
index c7f0147cb864..b76adc58a3d8 100644
--- a/net-libs/libssh2/Manifest
+++ b/net-libs/libssh2/Manifest
@@ -1,2 +1 @@
-DIST libssh2-1.9.0.tar.gz 888551 BLAKE2B 7bce5cd38b88654f0ca0f8b562e4bddc56346e3359e5873000cad7619607b2ec01c3945112dd8815d5de6daf650a750a4727cebe7d8996cc62f07ded06f3235f SHA512 41a3ebcf84e32eab69b7411ffb0a3b6e6db71491c968602b17392cfe3490ef00239726ec28acb3d25bf0ed62700db7f4d0bb5a9175618f413865f40badca6e17
DIST libssh2-1.9.0_p20190913.tar.gz 467616 BLAKE2B 2df7569aa118cf339340f32a106a547265a777af5834e0e22d18ac71946747e708c48d3125489b277b5c266d66cb35e7e224425bfc6a9b2e37e5d267fd7792b2 SHA512 0e095770b059b28aebd47a1219873bfe3b6e5775bbee5d526a7b6a287090e474ceac91c03b1b8a619a2a77916a110d8d20db22edc3cbfd1772190fb394a53f8a
diff --git a/net-libs/libssh2/files/libssh2-1.9.0-missing.patch b/net-libs/libssh2/files/libssh2-1.9.0-missing.patch
deleted file mode 100644
index 7cc58d239638..000000000000
--- a/net-libs/libssh2/files/libssh2-1.9.0-missing.patch
+++ /dev/null
@@ -1,181 +0,0 @@
---- /dev/null
-+++ b/tests/test_public_key_auth_succeeds_with_correct_ed25519_key.c
-@@ -0,0 +1,37 @@
-+#include "session_fixture.h"
-+
-+#include <libssh2.h>
-+
-+#include <stdio.h>
-+
-+static const char *USERNAME = "libssh2"; /* configured in Dockerfile */
-+static const char *KEY_FILE_PRIVATE = "key_ed25519";
-+static const char *KEY_FILE_PUBLIC = "key_ed25519.pub"; /* configured in Dockerfile */
-+
-+int test(LIBSSH2_SESSION *session)
-+{
-+ int rc;
-+ const char *userauth_list = NULL;
-+
-+ userauth_list = libssh2_userauth_list(session, USERNAME, strlen(USERNAME));
-+ if(userauth_list == NULL) {
-+ print_last_session_error("libssh2_userauth_list");
-+ return 1;
-+ }
-+
-+ if(strstr(userauth_list, "publickey") == NULL) {
-+ fprintf(stderr, "'publickey' was expected in userauth list: %s\n",
-+ userauth_list);
-+ return 1;
-+ }
-+
-+ rc = libssh2_userauth_publickey_fromfile_ex(
-+ session, USERNAME, strlen(USERNAME), KEY_FILE_PUBLIC, KEY_FILE_PRIVATE,
-+ NULL);
-+ if(rc != 0) {
-+ print_last_session_error("libssh2_userauth_publickey_fromfile_ex");
-+ return 1;
-+ }
-+
-+ return 0;
-+}
---- /dev/null
-+++ b/tests/test_public_key_auth_succeeds_with_correct_encrypted_ed25519_key.c
-@@ -0,0 +1,38 @@
-+#include "session_fixture.h"
-+
-+#include <libssh2.h>
-+
-+#include <stdio.h>
-+
-+static const char *USERNAME = "libssh2"; /* configured in Dockerfile */
-+static const char *PASSWORD = "libssh2";
-+static const char *KEY_FILE_PRIVATE = "key_ed25519_encrypted";
-+static const char *KEY_FILE_PUBLIC = "key_ed25519_encrypted.pub"; /* configured in Dockerfile */
-+
-+int test(LIBSSH2_SESSION *session)
-+{
-+ int rc;
-+ const char *userauth_list = NULL;
-+
-+ userauth_list = libssh2_userauth_list(session, USERNAME, strlen(USERNAME));
-+ if(userauth_list == NULL) {
-+ print_last_session_error("libssh2_userauth_list");
-+ return 1;
-+ }
-+
-+ if(strstr(userauth_list, "publickey") == NULL) {
-+ fprintf(stderr, "'publickey' was expected in userauth list: %s\n",
-+ userauth_list);
-+ return 1;
-+ }
-+
-+ rc = libssh2_userauth_publickey_fromfile_ex(
-+ session, USERNAME, strlen(USERNAME), KEY_FILE_PUBLIC, KEY_FILE_PRIVATE,
-+ PASSWORD);
-+ if(rc != 0) {
-+ print_last_session_error("libssh2_userauth_publickey_fromfile_ex");
-+ return 1;
-+ }
-+
-+ return 0;
-+}
---- /dev/null
-+++ b/tests/test_public_key_auth_succeeds_with_correct_ed25519_key_from_mem.c
-@@ -0,0 +1,97 @@
-+#include "session_fixture.h"
-+
-+#include <libssh2.h>
-+
-+#include <stdio.h>
-+#include <stdlib.h>
-+
-+static const char *USERNAME = "libssh2"; /* configured in Dockerfile */
-+static const char *KEY_FILE_ED25519_PRIVATE = "key_ed25519";
-+
-+int read_file(const char *path, char **buf, size_t *len);
-+
-+int test(LIBSSH2_SESSION *session)
-+{
-+ int rc;
-+ FILE *fp = NULL;
-+ char *buffer = NULL;
-+ size_t len = 0;
-+ const char *userauth_list = NULL;
-+
-+ userauth_list = libssh2_userauth_list(session, USERNAME, strlen(USERNAME));
-+ if(userauth_list == NULL) {
-+ print_last_session_error("libssh2_userauth_list");
-+ return 1;
-+ }
-+
-+ if(strstr(userauth_list, "publickey") == NULL) {
-+ fprintf(stderr, "'publickey' was expected in userauth list: %s\n",
-+ userauth_list);
-+ return 1;
-+ }
-+
-+ if(read_file(KEY_FILE_ED25519_PRIVATE, &buffer, &len)) {
-+ fprintf(stderr, "Reading key file failed.");
-+ return 1;
-+ }
-+
-+ rc = libssh2_userauth_publickey_frommemory(session, USERNAME, strlen(USERNAME),
-+ NULL, 0, buffer, len, NULL);
-+
-+ free(buffer);
-+
-+ if(rc != 0) {
-+ print_last_session_error("libssh2_userauth_publickey_fromfile_ex");
-+ return 1;
-+ }
-+
-+ return 0;
-+}
-+
-+int read_file(const char *path, char **out_buffer, size_t *out_len)
-+{
-+ int rc;
-+ FILE *fp = NULL;
-+ char *buffer = NULL;
-+ size_t len = 0;
-+
-+ if(out_buffer == NULL || out_len == NULL || path == NULL) {
-+ fprintf(stderr, "invalid params.");
-+ return 1;
-+ }
-+
-+ *out_buffer = NULL;
-+ *out_len = 0;
-+
-+ fp = fopen(path, "r");
-+
-+ if(!fp) {
-+ fprintf(stderr, "File could not be read.");
-+ return 1;
-+ }
-+
-+ fseek(fp, 0L, SEEK_END);
-+ len = ftell(fp);
-+ rewind(fp);
-+
-+ buffer = calloc(1, len + 1);
-+ if(!buffer) {
-+ fclose(fp);
-+ fprintf(stderr, "Could not alloc memory.");
-+ return 1;
-+ }
-+
-+ if(1 != fread(buffer, len, 1, fp)) {
-+ fclose(fp);
-+ free(buffer);
-+ fprintf(stderr, "Could not read file into memory.");
-+ return 1;
-+ }
-+
-+ fclose(fp);
-+
-+ *out_buffer = buffer;
-+ *out_len = len;
-+
-+ return 0;
-+}
diff --git a/net-libs/libssh2/libssh2-1.9.0-r1.ebuild b/net-libs/libssh2/libssh2-1.9.0-r1.ebuild
deleted file mode 100644
index a5602949511d..000000000000
--- a/net-libs/libssh2/libssh2-1.9.0-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit cmake-multilib
-
-DESCRIPTION="Library implementing the SSH2 protocol"
-HOMEPAGE="https://www.libssh2.org"
-SRC_URI="https://www.${PN}.org/download/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="gcrypt libressl mbedtls zlib"
-REQUIRED_USE="?? ( gcrypt mbedtls )"
-RESTRICT="test"
-
-RDEPEND="
- gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
- !gcrypt? (
- mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
- !mbedtls? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- )
- )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.0-mansyntax_sh.patch
- "${FILESDIR}"/${PN}-1.9.0-libdir.patch
- "${FILESDIR}"/${PN}-1.9.0-missing.patch
-)
-
-multilib_src_configure() {
- local crypto_backend=OpenSSL
- if use gcrypt; then
- crypto_backend=Libgcrypt
- elif use mbedtls; then
- crypto_backend=mbedTLS
- fi
-
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DCRYPTO_BACKEND=${crypto_backend}
- -DENABLE_ZLIB_COMPRESSION=$(usex zlib)
- )
- cmake-utils_src_configure
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/net-libs/libssh2/libssh2-1.9.0.ebuild b/net-libs/libssh2/libssh2-1.9.0.ebuild
deleted file mode 100644
index 73a2130ed835..000000000000
--- a/net-libs/libssh2/libssh2-1.9.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit cmake-multilib
-
-DESCRIPTION="Library implementing the SSH2 protocol"
-HOMEPAGE="https://www.libssh2.org"
-SRC_URI="https://www.${PN}.org/download/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="gcrypt libressl mbedtls zlib"
-REQUIRED_USE="?? ( gcrypt mbedtls )"
-RESTRICT="test"
-
-RDEPEND="
- gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
- !gcrypt? (
- mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
- !mbedtls? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- )
- )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.0-mansyntax_sh.patch
- "${FILESDIR}"/${PN}-1.9.0-missing.patch
-)
-
-multilib_src_configure() {
- local crypto_backend=OpenSSL
- if use gcrypt; then
- crypto_backend=Libgcrypt
- elif use mbedtls; then
- crypto_backend=mbedTLS
- fi
-
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DCRYPTO_BACKEND=${crypto_backend}
- -DENABLE_ZLIB_COMPRESSION=$(usex zlib)
- )
- cmake-utils_src_configure
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name '*.la' -delete || die
-}