summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-02 12:14:40 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-02 12:15:01 +0100
commitb76232050481bac15da359169021b7fb8475321c (patch)
tree4b1aa2f340d2c39370b2f3955fcb54d94a9c9148 /net-libs/libtelnet/libtelnet-0.23-r1.ebuild
parentdev-util/codeblocks: Fix x32 contrib plugins. Add boost-libdir option (diff)
downloadgentoo-b76232050481bac15da359169021b7fb8475321c.tar.gz
gentoo-b76232050481bac15da359169021b7fb8475321c.tar.bz2
gentoo-b76232050481bac15da359169021b7fb8475321c.zip
net-libs/libtelnet: Various ebuild improvements
- Add missing dependency on zlib, and missing BDEPEND on doxygen and pkgconfig - Unify release and 9999 ebuild skeletons - Update EAPI to 8, which also automatically passes --disable-static to econf so we don't need to manually remove static libraries in 0.23 anymore Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-libs/libtelnet/libtelnet-0.23-r1.ebuild')
-rw-r--r--net-libs/libtelnet/libtelnet-0.23-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libtelnet/libtelnet-0.23-r1.ebuild b/net-libs/libtelnet/libtelnet-0.23-r1.ebuild
new file mode 100644
index 000000000000..bf00b8db2d1e
--- /dev/null
+++ b/net-libs/libtelnet/libtelnet-0.23-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/seanmiddleditch/libtelnet.git"
+ inherit git-r3 cmake
+else
+ inherit autotools
+ SRC_URI="https://github.com/seanmiddleditch/libtelnet/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simple RFC-compliant TELNET implementation as a C library"
+HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
+
+LICENSE="public-domain"
+SLOT="0"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-doc/doxygen
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ if [[ ${PV} = *9999 ]]; then
+ eapply "${FILESDIR}"/${P}-doc.patch
+ cmake_src_prepare
+ else
+ eautoreconf
+ fi
+}