summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-29 05:29:26 +0100
committerSam James <sam@gentoo.org>2022-07-29 05:29:26 +0100
commitf3857ea8760d936de84b8461ff379e34e7d7430d (patch)
treed88e8c079e9766bbf78eeb1f9a2a5bf48c97c829 /net-libs/libtorrent-rasterbar
parentnet-libs/libtorrent-rasterbar: restore old 1.2.16 for now for crash bug (diff)
downloadgentoo-f3857ea8760d936de84b8461ff379e34e7d7430d.tar.gz
gentoo-f3857ea8760d936de84b8461ff379e34e7d7430d.tar.bz2
gentoo-f3857ea8760d936de84b8461ff379e34e7d7430d.zip
net-libs/libtorrent-rasterbar: add 1.2.17
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libtorrent-rasterbar')
-rw-r--r--net-libs/libtorrent-rasterbar/Manifest1
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.17.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/Manifest b/net-libs/libtorrent-rasterbar/Manifest
index c773058e84ab..84a402bc583f 100644
--- a/net-libs/libtorrent-rasterbar/Manifest
+++ b/net-libs/libtorrent-rasterbar/Manifest
@@ -1,3 +1,4 @@
DIST libtorrent-rasterbar-1.2.16.tar.gz 4163867 BLAKE2B 2cb4c79d83854bf3e5fc1b2ff9a361539b7690d0df3c2c15f2df1c7b9e782df51fbab57920a3bac56dff872c829a49303d66d33cdc10586ccc01dad3e83b149c SHA512 2bad1bf1604f99b85567056f798bfb78cdd663612291536d1145141e61f843aced416f7608911793c948d77802ef5b3088197b914c100a4278c94033eb304d4b
+DIST libtorrent-rasterbar-1.2.17.tar.gz 4167440 BLAKE2B 06e785e7ffa0e4f506b3f56f72bf5de96322ecc1d1ece542998b23412e72a73f230065c980cf2e86582b7d312b8623e22e3cd7b1974b44b287f95054e82c1513 SHA512 d2c702d8d942fb1e49e803f0684336bead40c219bf68764e193c34d335de03f0dcfb94f46d41447a7d95ec7063f314f64da0c385f3d5df310539b231063f6c0f
DIST libtorrent-rasterbar-2.0.6.tar.gz 4431174 BLAKE2B 4951a102b68a5a7ba9a98d771ca638e8438b2aeaa95f5d7bf616542c7a02d28e184ee1bf5b7a55cd91a068cd2d4e9756c479e4ddb5eabe89d8aa833d70aa7502 SHA512 4a5d710706040ef6193967dbb13998cb0ddebe7e95c3bf8aec0812876027c68c32b001fd3f07cd4ff1b819660a8d46ae8c7077e72caf92572288a51cdec7daea
DIST libtorrent-rasterbar-2.0.7.tar.gz 4453469 BLAKE2B b04884c55cb96031f6bfcef786ea101d18bb9310ec2e1ed528e27d8f625712855726575beae127f24c007144bb85e1eba293da748ad06794c58ebd9b38ec5aac SHA512 30e558245a261ccf3f23815a037477ae6da1a02da0b7b3aa40383058c5782a341a11ae684f959efc1c9b39e31475ec31451b9ff4b2db3c0bfccc4d42bd6d69c1
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.17.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.17.ebuild
new file mode 100644
index 000000000000..ee7e88d32406
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.17.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="https://libtorrent.org/ https://github.com/arvidn/libtorrent"
+SRC_URI="https://github.com/arvidn/libtorrent/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/10"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+dht debug python ssl test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/boost:=[threads(+)]
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ ')
+ )
+ ssl? ( dev-libs/openssl:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="python? (
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+ )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -Dbuild_examples=OFF
+ -Ddht=$(usex dht ON OFF)
+ -Dencryption=$(usex ssl ON OFF)
+ -Dlogging=$(usex debug ON OFF)
+ -Dpython-bindings=$(usex python ON OFF)
+ -Dbuild_tests=$(usex test ON OFF)
+ )
+
+ # We need to drop the . from the Python version to satisfy Boost's
+ # FindBoost.cmake module, bug #793038.
+ use python && mycmakeargs+=( -Dboost-python-module-name="${EPYTHON/./}" )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # Needs running UPnP server
+ -E "test_upnp"
+ )
+
+ # Checked out Fedora's test workarounds for inspiration
+ # https://src.fedoraproject.org/rpms/rb_libtorrent/blob/rawhide/f/rb_libtorrent.spec#_120
+ LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" cmake_src_test
+}