summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libtrace/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libtrace/files')
-rw-r--r--net-libs/libtrace/files/libtrace-3.0.20-autoconf-1.13.patch11
-rw-r--r--net-libs/libtrace/files/libtrace-3.0.20-libwandio-linking.patch8
-rw-r--r--net-libs/libtrace/files/libtrace-3.0.20-no-examples.patch11
-rw-r--r--net-libs/libtrace/files/libtrace-3.0.20-tinfo.patch21
4 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/libtrace/files/libtrace-3.0.20-autoconf-1.13.patch b/net-libs/libtrace/files/libtrace-3.0.20-autoconf-1.13.patch
new file mode 100644
index 000000000000..ed51ecb82868
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-3.0.20-autoconf-1.13.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -61,7 +61,7 @@
+ ])
+
+ # Put all our automake definitions in config.h
+-AM_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+
+ # Checks for C and C++ compilers
+ AC_PROG_CC
diff --git a/net-libs/libtrace/files/libtrace-3.0.20-libwandio-linking.patch b/net-libs/libtrace/files/libtrace-3.0.20-libwandio-linking.patch
new file mode 100644
index 000000000000..bed8ad945487
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-3.0.20-libwandio-linking.patch
@@ -0,0 +1,8 @@
+--- a/libwandio/Makefile.am
++++ b/libwandio/Makefile.am
+@@ -43,3 +43,5 @@
+ wandiocat_CFLAGS = -I"$(top_srcdir)/libwandio"
+ wandiocat_CXXFLAGS = -I"$(top_srcdir)/libwandio"
+ wandiocat_LDFLAGS = -L"$(top_srcdir)/libwandio" -lwandio
++
++wandiocat: libwandio.la
diff --git a/net-libs/libtrace/files/libtrace-3.0.20-no-examples.patch b/net-libs/libtrace/files/libtrace-3.0.20-no-examples.patch
new file mode 100644
index 000000000000..57983d036114
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-3.0.20-no-examples.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,7 @@
+ LIBPACKETDUMP_DIR = libpacketdump
+ TOOLS_DIR = tools
+ WANDIO_DIR=libwandio
+-SUBDIRS = $(WANDIO_DIR) lib $(LIBPACKETDUMP_DIR) $(TOOLS_DIR) docs examples
++SUBDIRS = $(WANDIO_DIR) lib $(LIBPACKETDUMP_DIR) $(TOOLS_DIR) docs
+
+ ACLOCAL_AMFLAGS = -I m4
+ AUTOMAKE_OPTIONS = 1.9 foreign
diff --git a/net-libs/libtrace/files/libtrace-3.0.20-tinfo.patch b/net-libs/libtrace/files/libtrace-3.0.20-tinfo.patch
new file mode 100644
index 000000000000..9bda8a43b6b2
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-3.0.20-tinfo.patch
@@ -0,0 +1,21 @@
+--- a/tools/tracetop/Makefile.am
++++ b/tools/tracetop/Makefile.am
+@@ -6,6 +6,6 @@
+ include ../Makefile.tools
+
+ tracetop_SOURCES = tracetop.cc
+-tracetop_LDADD = -lncurses
++tracetop_LDADD = @ncurses_LIBS@
+ tracetop_CPPFLAGS = -fno-strict-aliasing $(AM_CFLAGS)
+ endif
+--- a/configure.in
++++ b/configure.in
+@@ -492,6 +492,8 @@
+ fi
+ fi
+
++PKG_CHECK_MODULES(ncurses,ncurses)
++
+ AC_ARG_WITH([ncurses],
+ AC_HELP_STRING([--with-ncurses], [build tracetop (requires ncurses)]))
+