summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2020-01-23 20:13:46 +0000
committerIan Whyman <thev00d00@gentoo.org>2020-01-23 20:13:46 +0000
commitd3590ca1ed04e468b05d5ef329d94cc4bcc7e115 (patch)
tree8f5dbc07987dc43bb08f04ab0d5567c4e658e7e7 /net-libs/libupnp/libupnp-1.12.0.ebuild
parentdev-lang/go-bootstrap: fix manifest (diff)
downloadgentoo-d3590ca1ed04e468b05d5ef329d94cc4bcc7e115.tar.gz
gentoo-d3590ca1ed04e468b05d5ef329d94cc4bcc7e115.tar.bz2
gentoo-d3590ca1ed04e468b05d5ef329d94cc4bcc7e115.zip
net-libs/libupnp: Version bump to 1.12.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
Diffstat (limited to 'net-libs/libupnp/libupnp-1.12.0.ebuild')
-rw-r--r--net-libs/libupnp/libupnp-1.12.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-libs/libupnp/libupnp-1.12.0.ebuild b/net-libs/libupnp/libupnp-1.12.0.ebuild
new file mode 100644
index 000000000000..14fc805526fb
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.12.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic autotools vcs-snapshot
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/mrjimenez/pupnp/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc ipv6 +reuseaddr samples static-libs"
+
+DOCS="ChangeLog"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.21-cflags.patch
+)
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf $(use_enable debug) \
+ $(use_enable blocking-tcp blocking-tcp-connections) \
+ $(use_enable ipv6) \
+ $(use_enable reuseaddr) \
+ $(use_enable static-libs static) \
+ $(use_enable samples)
+}
+
+src_install () {
+ default
+
+ use static-libs || prune_libtool_files
+}