summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2023-01-14 10:25:51 -0600
committerErik Mackdanz <stasibear@gentoo.org>2023-01-15 15:25:00 -0600
commit1587a5eff30eb86bbe9e0b06d50a0eaf994a5c3a (patch)
tree25ff14b9f9b417d22cd324bc4361f754232fea9c /net-libs/libupnpp/libupnpp-0.22.4.ebuild
parentnet-libs/libupnpp: drop 0.21.0 (diff)
downloadgentoo-1587a5eff30eb86bbe9e0b06d50a0eaf994a5c3a.tar.gz
gentoo-1587a5eff30eb86bbe9e0b06d50a0eaf994a5c3a.tar.bz2
gentoo-1587a5eff30eb86bbe9e0b06d50a0eaf994a5c3a.zip
net-libs/libupnpp: add 0.22.4
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org>
Diffstat (limited to 'net-libs/libupnpp/libupnpp-0.22.4.ebuild')
-rw-r--r--net-libs/libupnpp/libupnpp-0.22.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-libs/libupnpp/libupnpp-0.22.4.ebuild b/net-libs/libupnpp/libupnpp-0.22.4.ebuild
new file mode 100644
index 000000000000..b05822c3f097
--- /dev/null
+++ b/net-libs/libupnpp/libupnpp-0.22.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DESCRIPTION="The libupnpp C++ library wraps libupnp for easier use by upmpdcli and upplay"
+HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli"
+SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/expat
+ net-libs/libnpupnp
+ net-misc/curl
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default_src_install
+ find "${ED}" -name '*.la' -delete || die "Couldn't delete .la files"
+}