summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2020-06-15 01:19:48 +0300
committerThomas Deutschmann <whissi@gentoo.org>2020-06-20 22:30:49 +0200
commit0220c0523306b9f439f4a2a2dd27d81b1a55ebcb (patch)
tree9d7d781d93d1040d57dc1e594bec91c9a0b617d9 /net-libs/libvncserver
parentnet-p2p/amule: Remove old revision (diff)
downloadgentoo-0220c0523306b9f439f4a2a2dd27d81b1a55ebcb.tar.gz
gentoo-0220c0523306b9f439f4a2a2dd27d81b1a55ebcb.tar.bz2
gentoo-0220c0523306b9f439f4a2a2dd27d81b1a55ebcb.zip
net-libs/libvncserver: Version bump to 0.9.13
Closes: https://bugs.gentoo.org/715964 Closes: https://bugs.gentoo.org/715968 Bug: https://bugs.gentoo.org/728594 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/16245 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-libs/libvncserver')
-rw-r--r--net-libs/libvncserver/Manifest1
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.13.ebuild71
-rw-r--r--net-libs/libvncserver/metadata.xml3
3 files changed, 74 insertions, 1 deletions
diff --git a/net-libs/libvncserver/Manifest b/net-libs/libvncserver/Manifest
index 17e32429ceef..836e8ec1e80a 100644
--- a/net-libs/libvncserver/Manifest
+++ b/net-libs/libvncserver/Manifest
@@ -1 +1,2 @@
DIST LibVNCServer-0.9.12.tar.gz 2237447 BLAKE2B 583500c0bcfb6e9e3a02a33fb2701113b164851f0906fcc4845de7c7d82d4f7f65f5edd6c9a672348ee1deeefc65c1b0a257da024254598ba86d121d424f027e SHA512 60ff1cc93a937d6f8f97449bc58b763095846207112f7b1b3c43eb2d74448b595d6da949903a764bd484ee54e38ff6277e882adbe965dd6d26ba15ef6ff6fcb8
+DIST LibVNCServer-0.9.13.tar.gz 567491 BLAKE2B 138c7ca63f8cd30a21dc1b58aafa744e12a1a9eca503ffec18a63d18791d7a5df4eef176d7e4e797a2aadda1dd04d1b051abfd76bf5c6806d558c09ffee78cce SHA512 18b0a1698d32bbdbfe6f65f76130b2a95860e3cc76e8adb904269663698c7c0ae982f451fda1f25e5461f096045d40a89d9014258f439366d5b4feaa4999d643
diff --git a/net-libs/libvncserver/libvncserver-0.9.13.ebuild b/net-libs/libvncserver/libvncserver-0.9.13.ebuild
new file mode 100644
index 000000000000..6a10ad068579
--- /dev/null
+++ b/net-libs/libvncserver/libvncserver-0.9.13.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_P="LibVNCServer-${PV}"
+
+DESCRIPTION="library for creating vnc servers"
+HOMEPAGE="https://libvnc.github.io/"
+SRC_URI="https://github.com/LibVNC/${PN}/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_P}"
+
+# common/d3des.*: https://github.com/LibVNC/libvncserver/issues/88
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+ BSD MIT"
+# no sub slot wanted (yet), see #578958
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+24bpp +filetransfer gcrypt gnutls ipv6 +jpeg libressl lzo +png sasl ssl systemd +threads +zlib"
+# https://bugs.gentoo.org/690202
+# https://bugs.gentoo.org/435326
+# https://bugs.gentoo.org/550916
+REQUIRED_USE="
+ filetransfer? ( threads )
+ jpeg? ( zlib )
+ png? ( zlib )
+ ssl? ( !gnutls? ( threads ) )
+"
+
+DEPEND="
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0= )
+ ssl? (
+ !gnutls? (
+ !libressl? ( >=dev-libs/openssl-1.0.2:0= )
+ libressl? ( >=dev-libs/libressl-2.7.0:0= )
+ )
+ gnutls? ( >=net-libs/gnutls-2.12.23-r6:0= )
+ )
+ jpeg? ( >=virtual/jpeg-0-r2:0 )
+ lzo? ( dev-libs/lzo )
+ png? ( >=media-libs/libpng-1.6.10:0= )
+ sasl? ( dev-libs/cyrus-sasl )
+ systemd? ( sys-apps/systemd:= )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1:0= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS.md README.md TODO.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_FFMPEG=OFF
+ -DWITH_GTK=OFF
+ -DWITH_SDL=OFF
+ -DWITH_24BPP=$(usex 24bpp ON OFF)
+ -DWITH_TIGHTVNC_FILETRANSFER=$(usex filetransfer ON OFF)
+ -DWITH_GCRYPT=$(usex gcrypt ON OFF)
+ -DWITH_GNUTLS=$(usex gnutls $(usex ssl ON OFF) OFF)
+ -DWITH_IPv6=$(usex ipv6 ON OFF)
+ -DWITH_JPEG=$(usex jpeg ON OFF)
+ -DWITH_LZO=$(usex lzo ON OFF)
+ -DWITH_OPENSSL=$(usex gnutls OFF $(usex ssl ON OFF))
+ -DWITH_PNG=$(usex png ON OFF)
+ -DWITH_SASL=$(usex sasl ON OFF)
+ -DWITH_SYSTEMD=$(usex systemd ON OFF)
+ -DWITH_THREADS=$(usex threads ON OFF)
+ -DWITH_ZLIB=$(usex zlib ON OFF)
+ )
+ cmake_src_configure
+}
diff --git a/net-libs/libvncserver/metadata.xml b/net-libs/libvncserver/metadata.xml
index 3d5cd2b505d6..c968122e3601 100644
--- a/net-libs/libvncserver/metadata.xml
+++ b/net-libs/libvncserver/metadata.xml
@@ -15,7 +15,8 @@
</longdescription>
<use>
<flag name="24bpp">Enable 24bpp support</flag>
- <flag name="gcrypt">Enable support for additional authentication methods via <pkg>dev-libs/libgcrypt</pkg></flag>
+ <flag name="filetransfer">Enable support for TightVNC's file transfer protocol</flag>
+ <flag name="gcrypt">Use <pkg>dev-libs/libgcrypt</pkg> as crypto backend</flag>
<flag name="lzo">Enable LZO support via <pkg>dev-libs/lzo</pkg> instead of using internal miniLZO implementation</flag>
</use>
<upstream>