summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-12-04 12:24:49 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-12-04 12:31:34 +0300
commitdbd47a7565fc01ad63c425694e2d8bd94932cce3 (patch)
tree33ace2ecbe806daf8d98db56c6b381904de03018 /net-libs/libyang/libyang-1.0.184.ebuild
parentwww-client/vivaldi-snapshot: Drop old 3.5.2115.31 (diff)
downloadgentoo-dbd47a7565fc01ad63c425694e2d8bd94932cce3.tar.gz
gentoo-dbd47a7565fc01ad63c425694e2d8bd94932cce3.tar.bz2
gentoo-dbd47a7565fc01ad63c425694e2d8bd94932cce3.zip
net-libs/libyang: new package
YANG data modelling language parser and toolkit written in C Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-libs/libyang/libyang-1.0.184.ebuild')
-rw-r--r--net-libs/libyang/libyang-1.0.184.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/libyang/libyang-1.0.184.ebuild b/net-libs/libyang/libyang-1.0.184.ebuild
new file mode 100644
index 000000000000..5c9ff1be96a1
--- /dev/null
+++ b/net-libs/libyang/libyang-1.0.184.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="YANG data modeling language library"
+HOMEPAGE="https://github.com/CESNET/libyang"
+SRC_URI="https://github.com/CESNET/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+
+RDEPEND="dev-libs/libpcre"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ doc? ( app-doc/doxygen[dot] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LYD_PRIV=yes
+ -DGEN_LANGUAGE_BINDINGS=no
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r "${S}"/doc/*
+}