summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2018-03-26 01:25:59 -0400
committerPacho Ramos <pacho@gentoo.org>2018-04-14 17:59:02 +0200
commitb5609fa27ea0e940719fa9b89302552fa43699e5 (patch)
treec828861b36f2aa440ec316cf68d7c702119cab1a /net-libs/loudmouth
parentnet-libs/nghttp2: amd64 stable (diff)
downloadgentoo-b5609fa27ea0e940719fa9b89302552fa43699e5.tar.gz
gentoo-b5609fa27ea0e940719fa9b89302552fa43699e5.tar.bz2
gentoo-b5609fa27ea0e940719fa9b89302552fa43699e5.zip
net-libs/loudmouth: Fix building with GCC-7
Bug: https://bugs.gentoo.org/618330 Closes: https://bugs.gentoo.org/618330 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'net-libs/loudmouth')
-rw-r--r--net-libs/loudmouth/files/loudmouth-1.5.3-gcc7.patch25
-rw-r--r--net-libs/loudmouth/loudmouth-1.5.3.ebuild3
2 files changed, 27 insertions, 1 deletions
diff --git a/net-libs/loudmouth/files/loudmouth-1.5.3-gcc7.patch b/net-libs/loudmouth/files/loudmouth-1.5.3-gcc7.patch
new file mode 100644
index 000000000000..83e0aea69d74
--- /dev/null
+++ b/net-libs/loudmouth/files/loudmouth-1.5.3-gcc7.patch
@@ -0,0 +1,25 @@
+Bug: https://bugs.gentoo.org/618330
+Upstream commit: https://github.com/mcabber/loudmouth/commit/01fdfa0f5d1b8502b92d2e78d757e9b19661d054
+
+From 01fdfa0f5d1b8502b92d2e78d757e9b19661d054 Mon Sep 17 00:00:00 2001
+From: tmp170422 <tmp131110@ya.ru>
+Date: Sun, 14 May 2017 12:18:32 +0300
+Subject: [PATCH] An apparent typo
+
+---
+ loudmouth/lm-sasl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/loudmouth/lm-sasl.c b/loudmouth/lm-sasl.c
+index 00cf9b7..38cd88c 100644
+--- a/loudmouth/lm-sasl.c
++++ b/loudmouth/lm-sasl.c
+@@ -529,7 +529,7 @@ sasl_md5_prepare_response (LmSASL *sasl, GHashTable *challenge)
+ }
+
+ nonce = g_hash_table_lookup (challenge, "nonce");
+- if (nonce == NULL || nonce == '\0') {
++ if (nonce == NULL || nonce[0] == '\0') {
+ g_log (LM_LOG_DOMAIN, LM_LOG_LEVEL_SASL,
+ "%s: server didn't provide a nonce in the challenge",
+ G_STRFUNC);
diff --git a/net-libs/loudmouth/loudmouth-1.5.3.ebuild b/net-libs/loudmouth/loudmouth-1.5.3.ebuild
index b5dac8fc2678..2b9a01dfa340 100644
--- a/net-libs/loudmouth/loudmouth-1.5.3.ebuild
+++ b/net-libs/loudmouth/loudmouth-1.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -34,6 +34,7 @@ DEPEND="${RDEPEND}
"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc7.patch
eautoreconf
}