summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-26 06:15:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-26 06:15:50 +0100
commit70a03a877eab63761c7f126bc1ea9616bee0a5ef (patch)
tree44638ec422db1dc9105a809776f699ef5f0c4ab4 /net-libs/miniupnpc/miniupnpc-2.2.3-r1.ebuild
parentdev-python/miniupnpc: Remove old (diff)
downloadgentoo-70a03a877eab63761c7f126bc1ea9616bee0a5ef.tar.gz
gentoo-70a03a877eab63761c7f126bc1ea9616bee0a5ef.tar.bz2
gentoo-70a03a877eab63761c7f126bc1ea9616bee0a5ef.zip
net-libs/miniupnpc: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/miniupnpc/miniupnpc-2.2.3-r1.ebuild')
-rw-r--r--net-libs/miniupnpc/miniupnpc-2.2.3-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/net-libs/miniupnpc/miniupnpc-2.2.3-r1.ebuild b/net-libs/miniupnpc/miniupnpc-2.2.3-r1.ebuild
deleted file mode 100644
index d4182dc8183b..000000000000
--- a/net-libs/miniupnpc/miniupnpc-2.2.3-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs verify-sig
-
-DESCRIPTION="UPnP client library and a simple UPnP client"
-HOMEPAGE="http://miniupnp.free.fr/"
-SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz
- verify-sig? ( http://miniupnp.free.fr/files/${P}.tar.gz.sig )"
-
-LICENSE="BSD"
-SLOT="0/17"
-KEYWORDS="amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="ipv6"
-
-RDEPEND=""
-BDEPEND="
- kernel_linux? ( sys-apps/lsb-release )
- verify-sig? ( sec-keys/openpgp-keys-miniupnp )"
-
-VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/miniupnp.asc
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}"/${P}-makefile.patch
- "${FILESDIR}"/${P}-drop-which.patch
- )
- default
-
- local exprs=(
- # These bins are not installed, upnpc-static requires building static lib
- -e '/EXECUTABLES =/s/ upnpc-static listdevices//'
- # Prevent gzipping manpage.
- -e '/gzip/d'
- # Disable installing the static library
- -e '/FILESTOINSTALL =/s/ $(LIBRARY)//'
- -e '/$(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(INSTALLDIRLIB)/d'
- )
- sed -i "${exprs[@]}" Makefile || die
-}
-
-# Upstream cmake causes more trouble than it fixes,
-# so we'll just stay with the Makefile for now.
-
-src_compile() {
- tc-export CC AR
- emake build/upnpc-shared
-}
-
-src_test() {
- emake -j1 HAVE_IPV6=$(usex ipv6) check
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- PREFIX="${EPREFIX}/usr" \
- INSTALLDIRLIB="${EPREFIX}/usr/$(get_libdir)" \
- install
-
- dodoc README Changelog.txt
-}