summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2018-01-22 21:04:58 +0100
committerSlawomir Lis <slis@gentoo.org>2018-01-22 22:00:28 +0100
commit89439bc945687107f70a81f8f16741e76a6af811 (patch)
treec0f5b00974f8a92ddd5e08d90573d98e480a114f /net-libs/nDPI/nDPI-2.2.ebuild
parentdev-ruby/jquery-ui-rails: cleanup (diff)
downloadgentoo-89439bc945687107f70a81f8f16741e76a6af811.tar.gz
gentoo-89439bc945687107f70a81f8f16741e76a6af811.tar.bz2
gentoo-89439bc945687107f70a81f8f16741e76a6af811.zip
net-libs/nDPI: version bump to 2.2
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'net-libs/nDPI/nDPI-2.2.ebuild')
-rw-r--r--net-libs/nDPI/nDPI-2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/nDPI/nDPI-2.2.ebuild b/net-libs/nDPI/nDPI-2.2.ebuild
new file mode 100644
index 000000000000..5db72a26125d
--- /dev/null
+++ b/net-libs/nDPI/nDPI-2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils multilib versionator
+
+DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
+HOMEPAGE="http://www.ntop.org/"
+SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-libs/json-c:=
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e "s/@NDPI_MAJOR@/$(get_version_component_range 1)/g;s/@NDPI_MINOR@/$(get_version_component_range 2)/g;s/@NDPI_PATCH@/$(get_version_component_range 3)/g;s/@NDPI_VERSION_SHORT@/${PV}/g" < "${S}/configure.seed" > "${S}/configure.ac" || die
+
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/lib${PN,,}.a || die
+ fi
+ prune_libtool_files
+}