summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-20 12:36:40 +0100
committerJeroen Roovers <jer@gentoo.org>2020-03-10 09:22:22 +0100
commit1b8579e788cde9eb445d8f9d360985747f7e2eb1 (patch)
tree4fd05762ca1cae4c7002bf7efb8a9c541b02a463 /net-libs/nDPI/nDPI-3.2.ebuild
parentnet-analyzer/ipband: Fix CFLAGS=-fno-common (diff)
downloadgentoo-1b8579e788cde9eb445d8f9d360985747f7e2eb1.tar.gz
gentoo-1b8579e788cde9eb445d8f9d360985747f7e2eb1.tar.bz2
gentoo-1b8579e788cde9eb445d8f9d360985747f7e2eb1.zip
net-libs/nDPI: Version 3.2
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/nDPI/nDPI-3.2.ebuild')
-rw-r--r--net-libs/nDPI/nDPI-3.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/nDPI/nDPI-3.2.ebuild b/net-libs/nDPI/nDPI-3.2.ebuild
new file mode 100644
index 000000000000..012aff2f4458
--- /dev/null
+++ b/net-libs/nDPI/nDPI-3.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools multilib
+
+DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
+HOMEPAGE="https://www.ntop.org/"
+SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ dev-libs/json-c:=
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ eval $(grep '^NDPI_MAJOR=' autogen.sh)
+ eval $(grep '^NDPI_MINOR=' autogen.sh)
+ eval $(grep '^NDPI_PATCH=' autogen.sh)
+ NDPI_VERSION_SHORT="${NDPI_MAJOR}.${NDPI_MINOR}.${NDPI_PATCH}"
+
+ sed \
+ -e "s/@NDPI_MAJOR@/${NDPI_MAJOR}/g" \
+ -e "s/@NDPI_MINOR@/${NDPI_MINOR}/g" \
+ -e "s/@NDPI_PATCH@/${NDPI_PATCH}/g" \
+ -e "s/@NDPI_VERSION_SHORT@/${NDPI_VERSION_SHORT}/g" \
+ < "${S}/configure.seed" \
+ > "${S}/configure.ac" || die
+
+ sed -i \
+ -e "s%^libdir\s*=\s*\${prefix}/lib\s*$%libdir = \${prefix}/$(get_libdir)%" \
+ src/lib/Makefile.in || die
+
+ default
+ eautoreconf
+
+ # Taken from autogen.sh (bug #704074):
+ sed -i \
+ -e "s/#define PACKAGE/#define NDPI_PACKAGE/g" \
+ -e "s/#define VERSION/#define NDPI_VERSION/g" \
+ configure || die
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/lib${PN,,}.a || die
+ fi
+}