summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/nacl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/nacl')
-rw-r--r--net-libs/nacl/Manifest1
-rw-r--r--net-libs/nacl/metadata.xml8
-rw-r--r--net-libs/nacl/nacl-0_p20110221.ebuild74
3 files changed, 83 insertions, 0 deletions
diff --git a/net-libs/nacl/Manifest b/net-libs/nacl/Manifest
new file mode 100644
index 000000000000..95565d1e87ac
--- /dev/null
+++ b/net-libs/nacl/Manifest
@@ -0,0 +1 @@
+DIST nacl-20110221.tar.bz2 163415 SHA256 4f277f89735c8b0b8a6bbd043b3efb3fa1cc68a9a5da6a076507d067fc3b3bf8 SHA512 4c031ceffe6a28dc74b46ac003d485531f78de467c802df73c8b22ca53644dabb7d2e3080b7bdd6583f0d07ad76b6d95bc0ffdce319ca2f80ee041e6fe618656 WHIRLPOOL 6fd80c68cf7c644189aba0e2cc72fd382149fc10fc69a208eaf5d51b45c3fbcc9a4a0284bf6dcfd05d34f1ef77ef7f3e735c68ce38dc3c4ca9f0412ac825a98a
diff --git a/net-libs/nacl/metadata.xml b/net-libs/nacl/metadata.xml
new file mode 100644
index 000000000000..5b80fb94c393
--- /dev/null
+++ b/net-libs/nacl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-libs/nacl/nacl-0_p20110221.ebuild b/net-libs/nacl/nacl-0_p20110221.ebuild
new file mode 100644
index 000000000000..5ff2e871e979
--- /dev/null
+++ b/net-libs/nacl/nacl-0_p20110221.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs multilib-minimal
+
+DESCRIPTION="high-speed software library for network communication, encryption, decryption, signatures"
+HOMEPAGE="http://nacl.cr.yp.to/"
+SRC_URI="http://hyperelliptic.org/nacl/${P/0_p}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/0_p}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/nacl/cpucycles.h
+ /usr/include/nacl/crypto_core_hsalsa20.h
+ /usr/include/nacl/crypto_hashblocks_sha256.h
+ /usr/include/nacl/crypto_hashblocks_sha512.h
+ /usr/include/nacl/crypto_onetimeauth_poly1305.h
+ /usr/include/nacl/crypto_scalarmult_curve25519.h
+ /usr/include/nacl/crypto_stream_aes128ctr.h
+ /usr/include/nacl/crypto_stream_salsa20.h
+ /usr/include/nacl/crypto_stream_salsa2012.h
+ /usr/include/nacl/crypto_stream_salsa208.h )
+
+src_prepare() {
+ #drop useless path elements, verbose output, predictable include dir
+ sed -e '/^export/d' \
+ -e '/^PATH/d' \
+ -e '/^LD_LIBRARY_PATH/d' \
+ -e '/^DYLD_LIBRARY_PATH/d' \
+ -e '/^exec >/d' \
+ -e '/^shorthostname/s:=.*:=gentoo:' \
+ -i do || die
+ sed -e 's:=== `date` === ::' \
+ -i $(find . -name do) || die
+ rm -r tests
+
+ multilib_copy_sources
+
+ filter-flags "-O*"
+ append-cflags -O3 -fomit-frame-pointer -funroll-loops
+ append-cxxflags -O3 -fomit-frame-pointer -funroll-loops
+}
+
+multilib_src_configure() {
+ echo "$(tc-getCC) ${CFLAGS}" > okcompilers/c
+ echo "$(tc-getCXX) ${CXXFLAGS}" > okcompilers/cpp
+ echo "$(tc-getAR)" > okcompilers/archivers
+
+ sed -e "1aexport PATH=\"${BUILD_DIR}/build/gentoo/bin:${PATH}\"" \
+ -i do || die
+}
+
+multilib_src_compile() {
+ ./do || die
+}
+
+multilib_src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ doins build/gentoo/lib/*/*
+
+ insinto /usr/include/${PN}
+ doins build/gentoo/include/*/*
+}