summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-28 10:15:05 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-28 10:28:53 +0100
commit3007a61c1e7f8d8060a372884a0e2a50bede4655 (patch)
tree3561b7fd9e0e47d0f0864750d2a461ba82969ce1 /net-libs/nghttp2
parentmedia-sound/mpg123: Removed old. (diff)
downloadgentoo-3007a61c1e7f8d8060a372884a0e2a50bede4655.tar.gz
gentoo-3007a61c1e7f8d8060a372884a0e2a50bede4655.tar.bz2
gentoo-3007a61c1e7f8d8060a372884a0e2a50bede4655.zip
net-libs/nghttp2: Bump to version 1.31.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.31.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 5fd139232548..18b7a201ad4e 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,3 +1,4 @@
DIST nghttp2-1.19.0.tar.gz 2159530 BLAKE2B 09e71408e527f5cd42ed224377042d4b68ff869e86c8727f63f2a4777253da9d03bd2cadfafd655b9984c7b71a52f928906db7b73d3adf74f36e69e28dba5618 SHA512 50f45082f725c237a0e1d25af57992b9cded6c9b68f0aa95c44c16eb4448e05b14e06c853032924d03034115286163de0ad684827cfa5d70896656868fdb4e01
DIST nghttp2-1.29.0.tar.xz 1544736 BLAKE2B 1708d2c787e27d722aec27890a21e752a9fe66cdcff481615ac0bd9dcc92099946d9e5563a70137029dec54f8cc4244ef22813e0c2010572cd070ff272120bdb SHA512 a518ff1dcc9ae93f8228f4fa9110b9cbc460260a794d455530218c66317c6b96a5b14971aff25428e37326b5ce9f4d8480eefe6fcba17af23efa4ebceb56f23e
DIST nghttp2-1.30.0.tar.xz 1545352 BLAKE2B 0d52f973a63632dc1ad235f1b535c24053a8dde52dfbda957c3e40548b4de5db5975639140f207cd9ffe564b6151ed6d97de45ff070eb2cfa3d6b41f52254430 SHA512 4b79f46947777627f0a9e1384ec51ac70e273aef6d46d322aa448731726b8ca606e73dcb171170bbe91fce93c28170ff04e11da56ee90fa28d642e7bc37b50be
+DIST nghttp2-1.31.0.tar.xz 1545800 BLAKE2B c0b8130abe7eb16e977cb8d480505d74c41986f15733da2005b1772b4030082c1c0c2e9a0576aae3e88922fc7b17ad9658e916641c3ddb816b45cc0e202b5bf4 SHA512 00342b0517eb9e1044eced4649488d7ad35694e0a1303c4cba2d2be897fb86c5c70f1a5a157799d5c0cf448a6b983f2a2a57ee2bdb5ec762876647f9303446ca
diff --git a/net-libs/nghttp2/nghttp2-1.31.0.ebuild b/net-libs/nghttp2/nghttp2-1.31.0.ebuild
new file mode 100644
index 000000000000..e578deb7b24b
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.31.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+SSL_DEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ cxx? (
+ ${SSL_DEPEND}
+ dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+ )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-werror
+ --without-cython
+ --disable-python-bindings
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+}