summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-10-08 09:03:50 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-10-08 09:03:50 +0200
commit312c7a0201e51630dce143bdb933bd2b007bde6f (patch)
tree2fc05778f2d64d510990a7f0098848ed320e36ab /net-libs/nghttp2
parentnet-firewall/xtables-addons: adopt new USE=modules logic (diff)
downloadgentoo-312c7a0201e51630dce143bdb933bd2b007bde6f.tar.gz
gentoo-312c7a0201e51630dce143bdb933bd2b007bde6f.tar.bz2
gentoo-312c7a0201e51630dce143bdb933bd2b007bde6f.zip
net-libs/nghttp2: Bump to version 1.34.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.34.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 5b2af1357ce1..2fd362e961de 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,3 +1,4 @@
DIST nghttp2-1.31.1.tar.xz 1545400 BLAKE2B 1d1a0982dc36928fe031c26d7adeca3364e0efbef43a7a2e01701614e128c3ab307321fc3e3166f09e71f002bd14d1ad5caaf3242502cbe4e71285591d8f2977 SHA512 e0f5b345b6d794b21fa04bc0c7125f24a877074538ad746451d4a293eb22f1afb9e0e619c69b84f0fc2142a925044a19976af4cffb8426358e95e7d9715d5a4f
DIST nghttp2-1.32.1.tar.xz 1548812 BLAKE2B a4c1f4f8d5070d1ddc5a5680d9fda28ad0b3ee6b1241b58b2be2b63026af249a1bcaf62c158c084061802ce93934dc5648e20c54887df330e07407d5879d1412 SHA512 477e6f4ccdba5c86436d554be819fd10a715896173029aa72f9c90c2ee64dbe20e2ff4cde614be3a7683dec9e0feaa21d124493ed5fc12ad4c63a37a83bad57c
DIST nghttp2-1.33.0.tar.xz 1554776 BLAKE2B 1b995d6385188423acbcd7c8b3a626a622270bc3079972885a1f707a9cc4ebb053f7347930ce217d2cf4277eab0a3309accb8f9ff18bd8ccc55c86aefa6246c3 SHA512 eeb0bf64fea115444c685c8a01c1017ce96be18adf88ffcdecad067de7012ca61c6b2b6a627b18e2572bba7bd77ec56a3ca4b1109f7a4b21220e8e28687b5b74
+DIST nghttp2-1.34.0.tar.xz 1612432 BLAKE2B b5a53d5ffdb68e509cebf50993c3b9de4e597ae9079db505db6e6df67c1eb5f4b095f18dec9f1b946f05b83f3db8ba15e5e5cd7efd4921a94350bd47533a9164 SHA512 5ddc4ab443c51ce286a656d2013421172fc37608f14c0a7ea02fa9e5a0dd155e162d5602b55f34dacc69709525a9a8110dc4c42d92607bbad1951075d094c6a0
diff --git a/net-libs/nghttp2/nghttp2-1.34.0.ebuild b/net-libs/nghttp2/nghttp2-1.34.0.ebuild
new file mode 100644
index 000000000000..990e99d6dd0c
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.34.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=7
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+SSL_DEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ cxx? (
+ ${SSL_DEPEND}
+ dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+ )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-werror
+ --without-cython
+ --disable-python-bindings
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+}