summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-04 10:25:51 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-04 10:30:16 +0200
commitfbd86a3373b1e84af11ca7ed0f40e0bcd42e85ac (patch)
tree80152a5f3d8409b3eb22c24fe63071f3bf97b1b6 /net-libs/nghttp2
parentdev-lang/crystal: fix PATH path when bootstrapping (diff)
downloadgentoo-fbd86a3373b1e84af11ca7ed0f40e0bcd42e85ac.tar.gz
gentoo-fbd86a3373b1e84af11ca7ed0f40e0bcd42e85ac.tar.bz2
gentoo-fbd86a3373b1e84af11ca7ed0f40e0bcd42e85ac.zip
net-libs/nghttp2: Bump to version 1.33.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.33.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 0130cf36b604..dcb62faae74e 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,3 +1,4 @@
DIST nghttp2-1.31.1.tar.xz 1545400 BLAKE2B 1d1a0982dc36928fe031c26d7adeca3364e0efbef43a7a2e01701614e128c3ab307321fc3e3166f09e71f002bd14d1ad5caaf3242502cbe4e71285591d8f2977 SHA512 e0f5b345b6d794b21fa04bc0c7125f24a877074538ad746451d4a293eb22f1afb9e0e619c69b84f0fc2142a925044a19976af4cffb8426358e95e7d9715d5a4f
DIST nghttp2-1.32.0.tar.xz 1548528 BLAKE2B 1a1d031fc23ac14236c58a84aa94ee255646d36c9c631000b5d48e39c9fbc16e1b28d82e40bfc96d0fb9e2aa6982ed6bff77bcecdacf220ba8dea0b86d92bcab SHA512 ec7e417fbc5497861d2b6dde5145da1640b36441882824e85940e5ca6ac52ec444aa7123846960f7211dd96462eab421d39f9cc49454f3f52e0dcdb36402044e
DIST nghttp2-1.32.1.tar.xz 1548812 BLAKE2B a4c1f4f8d5070d1ddc5a5680d9fda28ad0b3ee6b1241b58b2be2b63026af249a1bcaf62c158c084061802ce93934dc5648e20c54887df330e07407d5879d1412 SHA512 477e6f4ccdba5c86436d554be819fd10a715896173029aa72f9c90c2ee64dbe20e2ff4cde614be3a7683dec9e0feaa21d124493ed5fc12ad4c63a37a83bad57c
+DIST nghttp2-1.33.0.tar.xz 1554776 BLAKE2B 1b995d6385188423acbcd7c8b3a626a622270bc3079972885a1f707a9cc4ebb053f7347930ce217d2cf4277eab0a3309accb8f9ff18bd8ccc55c86aefa6246c3 SHA512 eeb0bf64fea115444c685c8a01c1017ce96be18adf88ffcdecad067de7012ca61c6b2b6a627b18e2572bba7bd77ec56a3ca4b1109f7a4b21220e8e28687b5b74
diff --git a/net-libs/nghttp2/nghttp2-1.33.0.ebuild b/net-libs/nghttp2/nghttp2-1.33.0.ebuild
new file mode 100644
index 000000000000..b8cb21f53b53
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.33.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=7
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+SSL_DEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ cxx? (
+ ${SSL_DEPEND}
+ dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+ )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-werror
+ --without-cython
+ --disable-python-bindings
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+}