summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-11 16:50:11 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-11 16:53:09 +0200
commit73ee71f5b874d8ee6ebceccfca87b4fa7b82491c (patch)
tree6d940305eca6531701b827bae5f6117089608d15 /net-libs/nodejs
parentnet-libs/nodejs: Old (diff)
downloadgentoo-73ee71f5b874d8ee6ebceccfca87b4fa7b82491c.tar.gz
gentoo-73ee71f5b874d8ee6ebceccfca87b4fa7b82491c.tar.bz2
gentoo-73ee71f5b874d8ee6ebceccfca87b4fa7b82491c.zip
net-libs/nodejs: Call xdg_environment_reset() from xdg-utils.eclass
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Bug: https://bugs.gentoo.org/625982 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/nodejs-10.16.3.ebuild4
-rw-r--r--net-libs/nodejs/nodejs-12.10.0.ebuild4
-rw-r--r--net-libs/nodejs/nodejs-12.11.1.ebuild4
-rw-r--r--net-libs/nodejs/nodejs-8.12.0.ebuild4
-rw-r--r--net-libs/nodejs/nodejs-8.16.1.ebuild4
-rw-r--r--net-libs/nodejs/nodejs-8.16.2.ebuild4
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild4
7 files changed, 21 insertions, 7 deletions
diff --git a/net-libs/nodejs/nodejs-10.16.3.ebuild b/net-libs/nodejs/nodejs-10.16.3.ebuild
index c2c2f3af8c6d..4dfee5eb4434 100644
--- a/net-libs/nodejs/nodejs-10.16.3.ebuild
+++ b/net-libs/nodejs/nodejs-10.16.3.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -92,6 +92,8 @@ src_prepare() {
}
src_configure() {
+ xdg_environment_reset
+
local myconf=( --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
use debug && myconf+=( --debug )
use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
diff --git a/net-libs/nodejs/nodejs-12.10.0.ebuild b/net-libs/nodejs/nodejs-12.10.0.ebuild
index 7cc1a7dd9a62..7a072e08f8c1 100644
--- a/net-libs/nodejs/nodejs-12.10.0.ebuild
+++ b/net-libs/nodejs/nodejs-12.10.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -90,6 +90,8 @@ src_prepare() {
}
src_configure() {
+ xdg_environment_reset
+
local myconf=(
--shared-cares --shared-http-parser --shared-libuv --shared-nghttp2
--shared-zlib
diff --git a/net-libs/nodejs/nodejs-12.11.1.ebuild b/net-libs/nodejs/nodejs-12.11.1.ebuild
index 47b66d3609c1..fdf342ca0430 100644
--- a/net-libs/nodejs/nodejs-12.11.1.ebuild
+++ b/net-libs/nodejs/nodejs-12.11.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -92,6 +92,8 @@ src_prepare() {
}
src_configure() {
+ xdg_environment_reset
+
local myconf=(
--shared-cares --shared-http-parser --shared-libuv --shared-nghttp2
--shared-zlib
diff --git a/net-libs/nodejs/nodejs-8.12.0.ebuild b/net-libs/nodejs/nodejs-8.12.0.ebuild
index ed7e641f54af..2e98f86fe29f 100644
--- a/net-libs/nodejs/nodejs-8.12.0.ebuild
+++ b/net-libs/nodejs/nodejs-8.12.0.ebuild
@@ -7,7 +7,7 @@ RESTRICT="test"
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -92,6 +92,8 @@ src_prepare() {
}
src_configure() {
+ xdg_environment_reset
+
local myconf=( --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
use debug && myconf+=( --debug )
use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
diff --git a/net-libs/nodejs/nodejs-8.16.1.ebuild b/net-libs/nodejs/nodejs-8.16.1.ebuild
index fa36bb45c983..fb4226a9a9d0 100644
--- a/net-libs/nodejs/nodejs-8.16.1.ebuild
+++ b/net-libs/nodejs/nodejs-8.16.1.ebuild
@@ -7,7 +7,7 @@ RESTRICT="test"
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -97,6 +97,8 @@ src_prepare() {
}
src_configure() {
+ xdg_environment_reset
+
local myconf=( --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
use debug && myconf+=( --debug )
use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
diff --git a/net-libs/nodejs/nodejs-8.16.2.ebuild b/net-libs/nodejs/nodejs-8.16.2.ebuild
index 8c46805762d1..621189a0947e 100644
--- a/net-libs/nodejs/nodejs-8.16.2.ebuild
+++ b/net-libs/nodejs/nodejs-8.16.2.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -97,6 +97,8 @@ src_prepare() {
}
src_configure() {
+ xdg_environment_reset
+
local myconf=( --shared-cares --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
use debug && myconf+=( --debug )
use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index 8f2196a20c61..098bb9968f85 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 flag-o-matic git-r3 pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic git-r3 pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -89,6 +89,8 @@ src_prepare() {
}
src_configure() {
+ xdg_environment_reset
+
local myconf=(
--shared-cares --shared-http-parser --shared-libuv --shared-nghttp2
--shared-zlib