summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-02 01:03:46 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-02 01:12:27 +0200
commit7a8be263e6dff1bddd8df185358465db14122266 (patch)
tree51db744203211a266feb15aea8e58410919ff1b8 /net-libs/nodejs
parentacct-user/github-exporter: fix group (diff)
downloadgentoo-7a8be263e6dff1bddd8df185358465db14122266.tar.gz
gentoo-7a8be263e6dff1bddd8df185358465db14122266.tar.bz2
gentoo-7a8be263e6dff1bddd8df185358465db14122266.zip
net-libs/nodejs: allow running tests for v14
...but print a warning if FEATURES=usersandbox is set because it is known to make one test fail. For v16, add the same warning but keep the restriction in place - the test suite fails because "npm is not ready for this release". v12 has got its own problems with the test suite so leave it be, Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/nodejs-14.16.1-r1.ebuild9
-rw-r--r--net-libs/nodejs/nodejs-16.0.0-r1.ebuild8
2 files changed, 14 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
index 0cc7ac183eeb..374542448516 100644
--- a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
@@ -22,8 +22,7 @@ REQUIRED_USE="inspector? ( icu ssl )
system-icu? ( icu )
system-ssl? ( ssl )"
-# FIXME: test-fs-mkdir fails with "no such file or directory". Investigate.
-RESTRICT="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=app-arch/brotli-1.0.9
>=dev-libs/libuv-1.40.0:=
@@ -223,6 +222,12 @@ src_install() {
}
src_test() {
+ # parallel/test-fs-mkdir is known to fail with FEATURES=usersandbox
+ if has usersandbox ${FEATURES}; then
+ ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+ "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ fi
+
out/${BUILDTYPE}/cctest || die
"${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
}
diff --git a/net-libs/nodejs/nodejs-16.0.0-r1.ebuild b/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
index e9b170f229d1..b93583878952 100644
--- a/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
+++ b/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
@@ -22,7 +22,7 @@ REQUIRED_USE="inspector? ( icu ssl )
system-icu? ( icu )
system-ssl? ( ssl )"
-# FIXME: test-fs-mkdir fails with "no such file or directory". Investigate.
+# As of 16.0.0, tests fail because "npm is not ready for this release"
RESTRICT="test"
RDEPEND=">=app-arch/brotli-1.0.9
@@ -217,6 +217,12 @@ src_install() {
}
src_test() {
+ # parallel/test-fs-mkdir is known to fail with FEATURES=usersandbox
+ if has usersandbox ${FEATURES}; then
+ ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+ "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ fi
+
out/${BUILDTYPE}/cctest || die
"${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
}