summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-03 22:10:37 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-03 23:28:35 -0400
commit30c2f36efb1baa5618431cf3d53cf5f2750c3639 (patch)
tree909b62a65c515f010f238b58b83a63e0f87fc34c /net-libs/phodav
parentdev-lang/vala: Fix Manifest (diff)
downloadgentoo-30c2f36efb1baa5618431cf3d53cf5f2750c3639.tar.gz
gentoo-30c2f36efb1baa5618431cf3d53cf5f2750c3639.tar.bz2
gentoo-30c2f36efb1baa5618431cf3d53cf5f2750c3639.zip
net-libs/phodav: Version bump to 2.5
Bug: https://bugs.gentoo.org/609390 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/phodav')
-rw-r--r--net-libs/phodav/Manifest1
-rw-r--r--net-libs/phodav/files/2.5-meson-Allow-specifying-systemd-udev-directories.patch79
-rw-r--r--net-libs/phodav/phodav-2.5.ebuild59
3 files changed, 139 insertions, 0 deletions
diff --git a/net-libs/phodav/Manifest b/net-libs/phodav/Manifest
index 96718b331e3d..543b0b63754a 100644
--- a/net-libs/phodav/Manifest
+++ b/net-libs/phodav/Manifest
@@ -1 +1,2 @@
DIST phodav-2.2.tar.xz 294216 BLAKE2B e7062f933f407dff339b050a8b735e733fa41634cc34b0a37556b283b941ff620ae59a2ed3b7bce41530195f33a9fb3113f89e37190bb046352d90d72a750468 SHA512 1d16716c1bda674a6695b651e9b1bcb4b7cfefd9b60291ed3f5691f4f6f45f68a970d99fc4820bed0484cf0a43c1bf32e4d208fcc239ac0c0b7a75bf779e8913
+DIST phodav-2.5.tar.xz 62992 BLAKE2B aca0141c20c727dd27af3760caf27ec0f7a4936c3c35dbdb60a8a15b5bd75ebd97dfef8bb96f50b266d7a0e53fb8c0e21416dea855ff107b362dba0e89283a64 SHA512 4b6cd6a40118bf9c042abcfc3e7cb593b620922aae4dd3daf77682bf9da2030a0958bc0206531d5950f85551ef8f5da21fb21c54b9bd5e56b880f54e0983bc01
diff --git a/net-libs/phodav/files/2.5-meson-Allow-specifying-systemd-udev-directories.patch b/net-libs/phodav/files/2.5-meson-Allow-specifying-systemd-udev-directories.patch
new file mode 100644
index 000000000000..004adccf0daa
--- /dev/null
+++ b/net-libs/phodav/files/2.5-meson-Allow-specifying-systemd-udev-directories.patch
@@ -0,0 +1,79 @@
+https://gitlab.gnome.org/GNOME/phodav/-/merge_requests/19
+
+From c67bd2f698e0e1c6d0747a1be6217e6e435ef798 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Mon, 3 May 2021 22:47:16 -0400
+Subject: [PATCH] meson: Allow specifying systemd/udev directories
+
+Closes: https://gitlab.gnome.org/GNOME/phodav/-/issues/1
+---
+ data/meson.build | 24 ++++++++++++++++++------
+ meson_options.txt | 12 ++++++------
+ 2 files changed, 24 insertions(+), 12 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index c466030..57ee6d1 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -1,16 +1,28 @@
+-systemd = dependency('systemd', required : get_option('systemd'))
+-if systemd.found()
++systemd_systemunitdir = get_option('systemdsystemunitdir')
++if systemd_systemunitdir == ''
++ systemd = dependency('systemd')
++ if systemd.found()
++ systemd_systemunitdir = systemd.get_pkgconfig_variable('systemdsystemunitdir')
++ endif
++endif
++if systemd_systemunitdir != ''
+ install_data(
+ 'spice-webdavd.service',
+- install_dir : systemd.get_pkgconfig_variable('systemdsystemunitdir')
++ install_dir : systemd_systemunitdir
+ )
+ endif
+
+-udev = dependency('udev', required : get_option('udev'))
+-if udev.found()
++udev_rulesdir = get_option('udevrulesdir')
++if udev_rulesdir == ''
++ udev = dependency('udev')
++ if udev.found()
++ udev_rulesdir = '@0@/@1@'.format(udev.get_pkgconfig_variable('udevdir'), 'rules.d')
++ endif
++endif
++if udev_rulesdir != ''
+ install_data(
+ '70-spice-webdavd.rules',
+- install_dir : '@0@/@1@'.format(udev.get_pkgconfig_variable('udevdir'), 'rules.d'),
++ install_dir : udev_rulesdir
+ )
+ endif
+
+diff --git a/meson_options.txt b/meson_options.txt
+index 724a0d3..1b075f5 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -6,13 +6,13 @@ option('avahi',
+ type : 'feature',
+ description : 'Build with avahi/mdns')
+
+-option('systemd',
+- type : 'feature',
+- description : 'Install systemd units/configuration')
++option('systemdsystemunitdir',
++ type: 'string',
++ description: 'Directory for systemd system unit files')
+
+-option('udev',
+- type : 'feature',
+- description : 'Install udev rules')
++option('udevrulesdir',
++ type : 'string',
++ description : 'Directory for udev rules')
+
+ option('build-id',
+ type : 'integer',
+--
+2.26.3
+
diff --git a/net-libs/phodav/phodav-2.5.ebuild b/net-libs/phodav/phodav-2.5.ebuild
new file mode 100644
index 000000000000..884a5f1534ba
--- /dev/null
+++ b/net-libs/phodav/phodav-2.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson systemd udev
+
+DESCRIPTION="WebDav server implementation using libsoup"
+HOMEPAGE="https://wiki.gnome.org/phodav"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="gtk-doc systemd zeroconf"
+
+RDEPEND="
+ >=dev-libs/glib-2.51.2:2
+ >=net-libs/libsoup-2.48:2.4
+ dev-libs/libxml2
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-meson-Allow-specifying-systemd-udev-directories.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use zeroconf ; then
+ sed -i -e 's|avahi-daemon.service||' data/spice-webdavd.service || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gtk-doc gtk_doc)
+ $(meson_feature zeroconf avahi)
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ -Dudevrulesdir="$(get_udevdir)/rules.d"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use systemd ; then
+ newinitd "${FILESDIR}/spice-webdavd.initd" spice-webdavd
+ udev_dorules "${FILESDIR}/70-spice-webdavd.rules"
+ fi
+}