summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/ptlib/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/ptlib/files')
-rw-r--r--net-libs/ptlib/files/ptlib-2.10.10-mga-bison-parameter.patch39
-rw-r--r--net-libs/ptlib/files/ptlib-2.10.10-respect_cflags_cxxflags.patch14
-rw-r--r--net-libs/ptlib/files/ptlib-2.10.9-disable-telnet-symbols.patch19
-rw-r--r--net-libs/ptlib/files/ptlib-2.10.9-pkgconfig_ldflags.patch11
-rw-r--r--net-libs/ptlib/files/ptlib-2.10.9-respect_cxxflags.patch10
-rw-r--r--net-libs/ptlib/files/ptlib-2.10.9-svn_revision_override.patch18
-rw-r--r--net-libs/ptlib/files/ptlib-2.12.4-respect_cxxflags.patch12
-rw-r--r--net-libs/ptlib/files/ptlib-2.12.4-sdl-linking.patch11
8 files changed, 134 insertions, 0 deletions
diff --git a/net-libs/ptlib/files/ptlib-2.10.10-mga-bison-parameter.patch b/net-libs/ptlib/files/ptlib-2.10.10-mga-bison-parameter.patch
new file mode 100644
index 000000000000..fcc8d0d2e7a8
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.10.10-mga-bison-parameter.patch
@@ -0,0 +1,39 @@
+--- ptlib-2.10.11/./src/ptlib/common/getdate.y 2013-08-15 01:20:26.000000000 +0200
++++ /mnt/chroot/cauldron/home/dan/rpm/BUILD/ptlib-2.10.11/src/ptlib/common/getdate.y 2013-12-15 00:24:27.866481490 +0100
+@@ -121,9 +121,9 @@
+ static int yylex();
+
+ #ifdef __GNUC__
+-static int yyerror(char const *msg);
++static int yyerror(void *, char const *msg);
+ #else
+-static void yyerror(char const *msg);
++static void yyerror(void *, char const *msg);
+ #endif
+
+
+@@ -132,7 +132,8 @@
+
+ %}
+
+-%pure_parser
++%pure-parser
++%parse-param {void *parseParam}
+
+ %union {
+ time_t Number;
+@@ -1018,12 +1019,12 @@
+ #endif
+
+ #ifdef __GNUC__
+-int yyerror(const char * s)
++int yyerror(void *var, const char * s)
+ {
+ return 0;
+ }
+ #else
+-static void yyerror(const char * s)
++static void yyerror(void *var, const char * s)
+ {
+ }
+ #endif
diff --git a/net-libs/ptlib/files/ptlib-2.10.10-respect_cflags_cxxflags.patch b/net-libs/ptlib/files/ptlib-2.10.10-respect_cflags_cxxflags.patch
new file mode 100644
index 000000000000..4442d333fcd1
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.10.10-respect_cflags_cxxflags.patch
@@ -0,0 +1,14 @@
+diff -ur ptlib-2.10.10.orig/make/ptbuildopts.mak.in ptlib-2.10.10/make/ptbuildopts.mak.in
+--- ptlib-2.10.10.orig/make/ptbuildopts.mak.in 2014-08-04 18:11:02.000000000 +0000
++++ ptlib-2.10.10/make/ptbuildopts.mak.in 2014-08-04 18:11:32.000000000 +0000
+@@ -15,8 +15,8 @@
+ OSTYPE = @OSTYPE@
+ OSRELEASE = @OSRELEASE@
+
+-STDCCFLAGS += @STDCCFLAGS@ @CPPFLAGS@
+-STDCXXFLAGS += @STDCXXFLAGS@ @CPPFLAGS@
++STDCCFLAGS += @STDCCFLAGS@ @CFLAGS@
++STDCXXFLAGS += @STDCXXFLAGS@ @CXXFLAGS@
+ OPTSTDCCFLAGS += @OPTSTDCCFLAGS@
+ LDFLAGS += @LDFLAGS@
+ ENDLDLIBS += @ENDLDLIBS@ \ No newline at end of file
diff --git a/net-libs/ptlib/files/ptlib-2.10.9-disable-telnet-symbols.patch b/net-libs/ptlib/files/ptlib-2.10.9-disable-telnet-symbols.patch
new file mode 100644
index 000000000000..0a3012c8510a
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.10.9-disable-telnet-symbols.patch
@@ -0,0 +1,19 @@
+diff -uNr ptlib-2.10.8.orig/src/ptclib/cli.cxx ptlib-2.10.8/src/ptclib/cli.cxx
+--- ptlib-2.10.8.orig/src/ptclib/cli.cxx 2012-10-19 13:45:35.000000000 -0400
++++ ptlib-2.10.8/src/ptclib/cli.cxx 2012-10-22 16:02:58.000000000 -0400
+@@ -858,6 +858,7 @@
+
+ ///////////////////////////////////////////////////////////////////////////////
+
++#ifdef HAS_TELNET
+ PCLITelnet::PCLITelnet(WORD port, const char * prompt, bool singleThreadForAll)
+ : PCLISocket(port, prompt, singleThreadForAll)
+ {
+@@ -868,6 +869,7 @@
+ {
+ return new PTelnetSocket();
+ }
++#endif
+
+
+ ///////////////////////////////////////////////////////////////////////////////
diff --git a/net-libs/ptlib/files/ptlib-2.10.9-pkgconfig_ldflags.patch b/net-libs/ptlib/files/ptlib-2.10.9-pkgconfig_ldflags.patch
new file mode 100644
index 000000000000..acd531977c3b
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.10.9-pkgconfig_ldflags.patch
@@ -0,0 +1,11 @@
+diff -uNr ptlib-2.10.8.orig/ptlib.pc.in ptlib-2.10.8/ptlib.pc.in
+--- ptlib-2.10.8.orig/ptlib.pc.in 2012-10-19 13:45:35.000000000 -0400
++++ ptlib-2.10.8/ptlib.pc.in 2012-10-19 14:03:26.000000000 -0400
+@@ -11,7 +11,7 @@
+ Name: ptlib
+ Description: PT Library
+ Version: @PTLIB_VERSION@
+-Libs: @LDFLAGS@ -L${libdir} -lpt${suffix}
++Libs: @ENDLDLIBS@ -L${libdir} -lpt${suffix}
+ Libs.private: @ENDLDLIBS@
+ Cflags: -I${includedir} @STDCCFLAGS@
diff --git a/net-libs/ptlib/files/ptlib-2.10.9-respect_cxxflags.patch b/net-libs/ptlib/files/ptlib-2.10.9-respect_cxxflags.patch
new file mode 100644
index 000000000000..dc09f960f05a
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.10.9-respect_cxxflags.patch
@@ -0,0 +1,10 @@
+diff -uNr ptlib-2.10.8.orig/configure.ac ptlib-2.10.8/configure.ac
+--- ptlib-2.10.8.orig/configure.ac 2012-10-19 13:45:35.000000000 -0400
++++ ptlib-2.10.8/configure.ac 2012-10-23 08:08:57.000000000 -0400
+@@ -538,7 +540,7 @@
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+- STDCXXFLAGS="$STDCCFLAGS -frtti"
++ STDCXXFLAGS="$STDCXXFLAGS -frtti"
+ fi
diff --git a/net-libs/ptlib/files/ptlib-2.10.9-svn_revision_override.patch b/net-libs/ptlib/files/ptlib-2.10.9-svn_revision_override.patch
new file mode 100644
index 000000000000..5531fd9f6fcb
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.10.9-svn_revision_override.patch
@@ -0,0 +1,18 @@
+diff -uNr ptlib-2.10.8.orig/src/ptlib/common/osutils.cxx ptlib-2.10.8/src/ptlib/common/osutils.cxx
+--- ptlib-2.10.8.orig/src/ptlib/common/osutils.cxx 2012-10-19 13:45:35.000000000 -0400
++++ ptlib-2.10.8/src/ptlib/common/osutils.cxx 2012-10-19 13:52:50.000000000 -0400
+@@ -43,13 +43,13 @@
+ #include <ptlib/svcproc.h>
+ #include <ptlib/pluginmgr.h>
+ #include "../../../version.h"
+-#include "../../../revision.h"
++# define SVN_REVISION 0
++//#include "../../../revision.h"
+
+ #ifdef _WIN32
+ #include <ptlib/msos/ptlib/debstrm.h>
+ #endif
+
+-
+ static const char * const VersionStatus[PProcess::NumCodeStatuses] = { "alpha", "beta", "." };
+ static const char DefaultRollOverPattern[] = "_yyyy_MM_dd_hh_mm";
diff --git a/net-libs/ptlib/files/ptlib-2.12.4-respect_cxxflags.patch b/net-libs/ptlib/files/ptlib-2.12.4-respect_cxxflags.patch
new file mode 100644
index 000000000000..85f590c8c88d
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.12.4-respect_cxxflags.patch
@@ -0,0 +1,12 @@
+diff -urN ptlib-2.12.4.old/configure.ac ptlib-2.12.4/configure.ac
+--- ptlib-2.12.4.old/configure.ac 2013-06-22 21:01:51.392606863 +0200
++++ ptlib-2.12.4/configure.ac 2013-06-22 21:02:02.991606450 +0200
+@@ -448,7 +448,7 @@
+ ],
+ [
+ AC_MSG_RESULT(no)
+- PTLIB_CXXFLAGS="$PTLIB_CFLAGS -frtti"
++ PTLIB_CXXFLAGS="$PTLIB_CXXFLAGS -frtti"
+ ]
+ )
+
diff --git a/net-libs/ptlib/files/ptlib-2.12.4-sdl-linking.patch b/net-libs/ptlib/files/ptlib-2.12.4-sdl-linking.patch
new file mode 100644
index 000000000000..91e5c0811d5d
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.12.4-sdl-linking.patch
@@ -0,0 +1,11 @@
+diff -urN ptlib-2.12.4/configure.ac ptlib-2.12.4.new/configure.ac
+--- ptlib-2.12.4/configure.ac 2013-06-21 07:02:48.000000000 +0200
++++ ptlib-2.12.4.new/configure.ac 2013-06-24 11:51:18.356368722 +0200
+@@ -1735,6 +1735,7 @@
+ PTLIB_CFLAGS="$PTLIB_CFLAGS ${SDL_CFLAGS}"
+ LDFLAGS="$LDFLAGS `pkg-config --libs sdl`"
+ ],[HAS_SDL=])
++ ENDLDLIBS="$ENDLDLIBS ${SDL_LIBS}"
+ fi
+ fi
+ AC_SUBST(HAS_SDL)