summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-03 14:34:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-03 15:00:57 +0100
commit7fa1fb1c758eaac7ea8975cd0fda0cc49b4d74ef (patch)
tree9634e76060de12719987e71f23d4a83b55074470 /net-libs/qxmpp/qxmpp-9999.ebuild
parentnet-p2p/qbittorrent: use HTTPS for HOMEPAGE (diff)
downloadgentoo-7fa1fb1c758eaac7ea8975cd0fda0cc49b4d74ef.tar.gz
gentoo-7fa1fb1c758eaac7ea8975cd0fda0cc49b4d74ef.tar.bz2
gentoo-7fa1fb1c758eaac7ea8975cd0fda0cc49b4d74ef.zip
net-libs/qxmpp: Simplify src_configure
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-libs/qxmpp/qxmpp-9999.ebuild')
-rw-r--r--net-libs/qxmpp/qxmpp-9999.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/net-libs/qxmpp/qxmpp-9999.ebuild b/net-libs/qxmpp/qxmpp-9999.ebuild
index 21806f48a186..d9226e906b66 100644
--- a/net-libs/qxmpp/qxmpp-9999.ebuild
+++ b/net-libs/qxmpp/qxmpp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -45,17 +45,14 @@ src_prepare(){
default_src_prepare
}
-src_configure(){
- local conf_speex
- local conf_theora
- local conf_vpx
-
- use opus && conf_opus="QXMPP_USE_OPUS=1"
- use speex && conf_speex="QXMPP_USE_SPEEX=1"
- use theora && conf_theora="QXMPP_USE_THEORA=1"
- use vpx && conf_vpx="QXMPP_USE_VPX=1"
-
- eqmake5 "${S}"/qxmpp.pro "PREFIX=${EPREFIX}/usr" "LIBDIR=$(get_libdir)" "${conf_opus}" "${conf_speex}" "${conf_theora}" "${conf_vpx}"
+src_configure() {
+ eqmake5 "${S}"/qxmpp.pro \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="$(get_libdir)" \
+ QXMPP_USE_OPUS=$(usex opus 1 0) \
+ QXMPP_USE_SPEEX=$(usex speex 1 0) \
+ QXMPP_USE_THEORA=$(usex theora 1 0) \
+ QXMPP_USE_VPX=$(usex vpx 1 0)
}
src_install() {