summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-25 18:11:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-25 18:14:45 +0200
commitcde66f63160f1d4669cbacc51bbf6e2a6e922445 (patch)
tree6a5d31235da020caca58b2a5f80427e288299cba /net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild
parentapp-office/libreoffice: Fix build with poppler-0.64 (diff)
downloadgentoo-cde66f63160f1d4669cbacc51bbf6e2a6e922445.tar.gz
gentoo-cde66f63160f1d4669cbacc51bbf6e2a6e922445.tar.bz2
gentoo-cde66f63160f1d4669cbacc51bbf6e2a6e922445.zip
net-libs/telepathy-qt: Cleanup bogus deps, cleanup failing test deps
Closes: https://bugs.gentoo.org/653802 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild')
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild25
1 files changed, 5 insertions, 20 deletions
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild
index 9aaa8c5aa7c1..97dc81e956dd 100644
--- a/net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.7-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit python-any-r1 cmake-utils virtualx
+inherit python-any-r1 cmake-utils
DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
HOMEPAGE="https://telepathy.freedesktop.org/"
@@ -13,7 +13,7 @@ SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="debug farstream test"
+IUSE="debug farstream"
RDEPEND="
dev-qt/qtcore:5
@@ -29,17 +29,12 @@ RDEPEND="
DEPEND="${RDEPEND}
${PYTHON_DEPS}
virtual/pkgconfig
- test? (
- dev-libs/dbus-glib
- dev-libs/glib:2
- dev-python/dbus-python
- dev-qt/qttest:5
- )
"
PATCHES=(
"${FILESDIR}/${PN}-0.9.6.1-yes-release.patch"
"${FILESDIR}/${PN}-0.9.6.1-qtpath.patch"
+ "${FILESDIR}/${P}-deps.patch"
)
# bug 549448 - last checked with 0.9.7
@@ -54,18 +49,8 @@ src_configure() {
-DDESIRED_QT_VERSION=5
-DENABLE_DEBUG_OUTPUT=$(usex debug)
-DENABLE_FARSTREAM=$(usex farstream)
- -DENABLE_TESTS=$(usex test)
+ -DENABLE_TESTS=OFF
-DENABLE_EXAMPLES=OFF
)
cmake-utils_src_configure
}
-
-src_test() {
- _test_runner() {
- ctest -E '(CallChannel)'
- }
-
- pushd "${BUILD_DIR}" > /dev/null || die
- virtx _test_runner
- popd > /dev/null || die
-}