summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosiah Mullins <jomull01@protonmail.com>2019-10-18 21:57:21 -0400
committerJoonas Niilola <juippis@gentoo.org>2019-11-04 08:07:42 +0200
commit9e2eb6cf66ed0095be122abec0d033d9dbc77417 (patch)
tree92432d33f87545a0c59b1fe40b0cadf4c118c495 /net-libs/tox/tox-9999.ebuild
parentacct-user/tox: new package (diff)
downloadgentoo-9e2eb6cf66ed0095be122abec0d033d9dbc77417.tar.gz
gentoo-9e2eb6cf66ed0095be122abec0d033d9dbc77417.tar.bz2
gentoo-9e2eb6cf66ed0095be122abec0d033d9dbc77417.zip
net-libs/tox: update tox-9999
This commit introduces compatability with GLEP 81; updates the EAPI from 6 to 7; updates the cflags options; disables dht-node by default; and optimizes the package requirement section. Signed-off-by: Josiah Mullins <JoMull01@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs/tox/tox-9999.ebuild')
-rw-r--r--net-libs/tox/tox-9999.ebuild89
1 files changed, 65 insertions, 24 deletions
diff --git a/net-libs/tox/tox-9999.ebuild b/net-libs/tox/tox-9999.ebuild
index 3c267ef0e1e2..501b16dc7266 100644
--- a/net-libs/tox/tox-9999.ebuild
+++ b/net-libs/tox/tox-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3 systemd user
+inherit cmake-utils git-r3 systemd
DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
HOMEPAGE="https://tox.chat"
@@ -13,29 +13,66 @@ EGIT_REPO_URI="https://github.com/TokTok/c-toxcore.git"
LICENSE="GPL-3+"
SLOT="0/0.2"
KEYWORDS=""
-IUSE="+av daemon log-debug log-trace +no-log static-libs test"
+IUSE="+av daemon dht-node ipv6 log-debug +log-error log-info log-trace log-warn static-libs test"
-REQUIRED_USE="^^ ( no-log log-trace log-debug )"
+REQUIRED_USE="^^ ( log-debug log-error log-info log-trace log-warn )
+ daemon? ( dht-node )"
-RDEPEND="
- av? ( media-libs/libvpx:=
+COMMON_DEPEND="
+ av? ( media-libs/libvpx
media-libs/opus )
- daemon? ( dev-libs/libconfig )
+ daemon? ( acct-group/tox
+ acct-user/tox
+ dev-libs/libconfig )
>=dev-libs/libsodium-0.6.1:=[asm,urandom,-minimal]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
+
+DEPEND="${COMMON_DEPEND}"
+
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ #remove faulty tests
+ for testname in bootstrap lan_discovery save_compatibility tcp_relay tox_many_tcp; do
+ sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
+ done
+}
src_configure() {
local mycmakeargs=(
- -DTRACE=$(usex log-trace)
- -DDEBUG=$(usex log-debug)
- -DBUILD_TOXAV=$(usex av)
- -DMUST_BUILD_TOXAV=$(usex av)
- -DBUILD_AV_TEST=$(usex av)
+ -DAUTOTEST=$(usex test)
-DBOOTSTRAP_DAEMON=$(usex daemon)
+ -DBUILD_TOXAV=$(usex av)
+ -DDHT_BOOTSTRAP=$(usex dht-node)
+ -DENABLE_SHARED=ON
-DENABLE_STATIC=$(usex static-libs)
- )
+ -DMUST_BUILD_TOXAV=$(usex av))
+ if use test; then
+ mycmakeargs+=(
+ -DBUILD_AV_TEST=$(usex av)
+ -DTEST_TIMEOUT_SECONDS=120
+ -DUSE_IPV6=$(usex ipv6))
+ else
+ mycmakeargs+=(
+ -DBUILD_AV_TEST=OFF
+ -DUSE_IPV6=OFF)
+ fi
+ if use log-trace; then
+ mycmakeargs+=(-DMIN_LOGGER_LEVEL="TRACE")
+ elif use log-debug; then
+ mycmakeargs+=(-DMIN_LOGGER_LEVEL="DEBUG")
+ elif use log-info; then
+ mycmakeargs+=(-DMIN_LOGGER_LEVEL="INFO")
+ elif use log-warn; then
+ mycmakeargs+=(-DMIN_LOGGER_LEVEL="WARNING")
+ elif use log-error; then
+ mycmakeargs+=(-DMIN_LOGGER_LEVEL="ERROR")
+ else
+ mycmakeargs+=(-DMIN_LOGGER_LEVEL="")
+ einfo "Logging Disabled"
+ fi
cmake-utils_src_configure
}
@@ -49,20 +86,24 @@ src_install() {
doins "${FILESDIR}"/tox-bootstrapd.conf
systemd_dounit "${FILESDIR}"/tox-bootstrapd.service
fi
-
- find "${D}" -name '*.la' -delete || die
}
pkg_postinst() {
+ if use dht-node; then
+ ewarn "There is currently an unresolved issue with tox"
+ ewarn "DHT Bootstrap node that causes the program to be"
+ ewarn "built with a null library reference. This"
+ ewarn "causes an infinite loop for certain rev-dep-rebuild"
+ ewarn "commands. If you aren't running a node, please"
+ ewarn "consider disabling the dht-node flag"
+ fi
if use daemon; then
- enewgroup tox
- enewuser tox -1 -1 -1 tox
- if [[ -f ${EROOT%/}/var/lib/tox-dht-bootstrap/key ]]; then
+ if [[ -f ${EROOT}/var/lib/tox-dht-bootstrap/key ]]; then
ewarn "Backwards compatability with the bootstrap daemon might have been"
ewarn "broken a while ago. To resolve this issue, REMOVE the following files:"
- ewarn " ${EROOT%/}/var/lib/tox-dht-bootstrap/key"
- ewarn " ${EROOT%/}/etc/tox-bootstrapd.conf"
- ewarn " ${EROOT%/}/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
+ ewarn " ${EROOT}/var/lib/tox-dht-bootstrap/key"
+ ewarn " ${EROOT}/etc/tox-bootstrapd.conf"
+ ewarn " ${EROOT}/run/tox-dht-bootstrap/tox-dht-bootstrap.pid"
ewarn "Then just re-emerge net-libs/tox"
fi
fi