summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-04 20:55:44 +0000
committerSam James <sam@gentoo.org>2020-09-04 20:56:31 +0000
commitf639e5bfbbd2eae0a5eed22e4af32287bc57f039 (patch)
treeb3a3d236af9f74d6d43e9049d5a02655cd5421cf /net-libs/tox/tox-9999.ebuild
parentnet-libs/tox: update to tox-9999 (diff)
downloadgentoo-f639e5bfbbd2eae0a5eed22e4af32287bc57f039.tar.gz
gentoo-f639e5bfbbd2eae0a5eed22e4af32287bc57f039.tar.bz2
gentoo-f639e5bfbbd2eae0a5eed22e4af32287bc57f039.zip
net-libs/tox: minor style changes
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/tox/tox-9999.ebuild')
-rw-r--r--net-libs/tox/tox-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/net-libs/tox/tox-9999.ebuild b/net-libs/tox/tox-9999.ebuild
index 23e322bf207c..6e0181ca0d85 100644
--- a/net-libs/tox/tox-9999.ebuild
+++ b/net-libs/tox/tox-9999.ebuild
@@ -35,8 +35,10 @@ RDEPEND="
src_prepare() {
cmake_src_prepare
- #remove faulty tests
+
+ # Remove faulty tests
local faultytest=(lan_discovery save_compatibility)
+ local testname=
for testname in "${faultytest[@]}"; do
sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
done
@@ -51,14 +53,16 @@ src_configure() {
-DDHT_BOOTSTRAP=$(usex dht-node)
-DENABLE_SHARED=ON
-DENABLE_STATIC=$(usex static-libs)
- -DMUST_BUILD_TOXAV=$(usex av))
+ -DMUST_BUILD_TOXAV=$(usex av)
+ )
+
if use test; then
mycmakeargs+=(
-DTEST_TIMEOUT_SECONDS=120
- -DUSE_IPV6=$(usex ipv6))
+ -DUSE_IPV6=$(usex ipv6)
+ )
else
- mycmakeargs+=(
- -DUSE_IPV6=OFF)
+ mycmakeargs+=(-DUSE_IPV6=OFF)
fi
if use log-trace; then